# CVE-2021-28833: qiita-markdown Cross-site Scripting vulnerability

> Attackers can execute arbitrary scripts in user browsers via crafted gist links in the Qiita::Markdown Ruby library.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 21 Jun 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-9p29-94hp-8rvc

## What is CVE-2021-28833?

CVE-2021-28833 is a medium-severity cross-site scripting vulnerability in n/a, published on 21 Jun 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Increments Qiita::Markdown before 0.34.0 allows XSS via a crafted gist link, a different vulnerability than CVE-2021-28796.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-28833?

2 open source packages ship an affected version, including qiita-markdown. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `qiita-markdown` | RubyGems | All versions | 0.34.0 |
| `qiita-markdown` | RubyGems | All versions | 0.34.0 |

Products: Increments Qiita\.

## How do I fix CVE-2021-28833?

Upgrade qiita-markdown to 0.34.0 or later.

## Is CVE-2021-28833 being exploited?

There is no known exploitation of CVE-2021-28833 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2021-28796](https://insights.sbomify.com/CVE-2021-28796/): Cross-Site Scripting in Qiita-Markdown (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-28833 and fix it if it is affected.

What it is: CVE-2021-28833 is a medium-severity cross-site scripting vulnerability in n/a, published on 21 Jun 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-28833 in the wild and no public exploit code.

Affected packages and fixed versions:
- qiita-markdown (RubyGems): affected all versions; fixed in 0.34.0
- qiita-markdown (RubyGems): affected all versions; fixed in 0.34.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-28833/ (Markdown: https://insights.sbomify.com/CVE-2021-28833/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-28833
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-28833
- OSV: https://osv.dev/vulnerability/CVE-2021-28833

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-28833/
Summaries are generated and may contain mistakes; the official description above is the record.
