# CVE-2021-28957: lxml vulnerable to Cross-Site Scripting

> Remote attackers can execute arbitrary JavaScript via XSS in python-lxml when specific sanitizer options are disabled, affecting applications using the library.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 21 Mar 2021
- **Updated:** 17 Dec 2025
- **Also known as:** ALPINE-CVE-2021-28957, ALSA-2021:4158, AZL-6808, DEBIAN-CVE-2021-28957, DLA-2606-1, DSA-4880-1, GHSA-jq4v-f5q6-mjqq, MGASA-2021-0246, OESA-2021-1178, PYSEC-2021-19, RHSA-2021:4158, RLSA-2021:4158, SUSE-SU-2022:3934-1, SUSE-SU-2022:3937-1, UBUNTU-CVE-2021-28957, USN-4896-1, USN-4896-2, openSUSE-SU-2024:11473-1, openSUSE-SU-2025:14647-1

## What is CVE-2021-28957?

CVE-2021-28957 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 21 Mar 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

An XSS vulnerability was discovered in python-lxml's clean module versions before 4.6.3. When disabling the safe_attrs_only and forms arguments, the Cleaner class does not remove the formaction attribute allowing for JS to bypass the sanitizer. A remote attacker could exploit this flaw to run arbitrary JS code on users who interact with incorrectly sanitized HTML. This issue is patched in lxml 4.6.3.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-28957?

3 open source packages ship an affected version, including lxml. It affects 5 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `lxml` | PyPI | All versions | 4.6.3 |
| `lxml` | PyPI | All versions | 4.6.3 |
| `lxml` | PyPI | All versions | 4.6.3 |
| `python3-lxml` | AlmaLinux:8 | All versions | 4.2.3-3.el8 |
| `python-lxml` | Red Hat:enterprise_linux:8::appstream | All versions | 0:4.2.3-3.el8 |
| `python-lxml-debugsource` | Red Hat:enterprise_linux:8::appstream | All versions | 0:4.2.3-3.el8 |
| `python3-lxml` | Red Hat:enterprise_linux:8::appstream | All versions | 0:4.2.3-3.el8 |
| `python3-lxml-debuginfo` | Red Hat:enterprise_linux:8::appstream | All versions | 0:4.2.3-3.el8 |
| `python-lxml` | Rocky Linux:8 | All versions | 0:4.2.3-3.el8 |
| `python3-lxml` | SUSE:Linux Enterprise Module for Public Cloud 12 | All versions | 3.3.5-3.15.1 |
| `python3-lxml` | SUSE:Linux Enterprise Server 12 SP5 | All versions | 3.6.1-3.6.1 |
| `python3-lxml` | SUSE:Linux Enterprise Server for SAP Applications 12 SP5 | All versions | 3.6.1-3.6.1 |
| `translate-toolkit` | openSUSE:Tumbleweed | All versions | 3.14.5-1.1 |
| `translate-toolkit` | openSUSE:Tumbleweed | All versions | 3.3.6-1.3 |

Products: Debian Debian Linux, Fedoraproject Fedora, Lxml Lxml, Netapp Snapcenter, Oracle Zfs Storage Appliance Kit.

## How do I fix CVE-2021-28957?

Upgrade lxml to 4.6.3 or later.

## Is CVE-2021-28957 being exploited?

There is no known exploitation of CVE-2021-28957 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-28957 and fix it if it is affected.

What it is: CVE-2021-28957 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 21 Mar 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-28957 in the wild and no public exploit code.

Affected packages and fixed versions:
- lxml (PyPI): affected all versions; fixed in 4.6.3
- lxml (PyPI): affected all versions; fixed in 4.6.3
- lxml (PyPI): affected all versions; fixed in 4.6.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-28957/ (Markdown: https://insights.sbomify.com/CVE-2021-28957/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-28957
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-28957
- OSV: https://osv.dev/vulnerability/CVE-2021-28957

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-28957/
Summaries are generated and may contain mistakes; the official description above is the record.
