{"answers":{"affected":"4 open source packages ship an affected version, including rexml, ruby and ruby-min. It affects 3 products.","exploited":"There is no known exploitation of CVE-2021-28965 in the wild and no public exploit code.","fix":"Upgrade rexml to 3.2.5 or later.","what":"CVE-2021-28965 is a high-severity vulnerability in Fedoraproject Fedora, published on 21 Apr 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-28965 and fix it if it is affected.\n\nWhat it is: CVE-2021-28965 is a high-severity vulnerability in Fedoraproject Fedora, published on 21 Apr 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-28965 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- rexml (RubyGems): affected all versions; fixed in 3.2.5\n- rexml (RubyGems): affected all versions; fixed in 3.2.5\n- ruby (Bitnami): affected all versions; fixed in 2.6.7, 2.7.3, 3.0.1\n- ruby-min (Bitnami): affected all versions; fixed in 2.6.7, 2.7.3, 3.0.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-28965/ (Markdown: https://insights.sbomify.com/CVE-2021-28965/index.md)","id":"CVE-2021-28965","markdown":"https://insights.sbomify.com/CVE-2021-28965/index.md","name":"CVE-2021-28965","record":{"aliases":["ALPINE-CVE-2021-28965","AZL-6860","BIT-ruby-2021-28965","BIT-ruby-min-2021-28965","CLEANSTART-2026-BM82320","DEBIAN-CVE-2021-28965","GHSA-8cr8-4vfw-mr7h","JLSEC-2026-1282","OESA-2021-1259","SUSE-SU-2021:1280-1","UBUNTU-CVE-2021-28965","USN-4922-1","openSUSE-SU-2021:0607-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby REXML library","requires_auth":"none","summary":"An attacker can cause data corruption by exploiting improper XML round-trip handling in the REXML library, leading to incorrect document serialization.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"fedora","vendor":"fedoraproject"},{"product":"rexml","vendor":"ruby-lang"},{"product":"ruby","vendor":"ruby-lang"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[],"description":"The REXML gem before 3.2.5 in Ruby before 2.6.7, 2.7.x before 2.7.3, and 3.x before 3.0.1 does not properly address XML round-trip issues. An incorrect document can be produced after parsing and serializing.","ecosystems":["Bitnami","RubyGems","SUSE:Linux Enterprise Micro 5.0","SUSE:Linux Enterprise Module for Basesystem 15 SP2","openSUSE:Leap 15.2"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"REXML round-trip instability","id":"CVE-2021-28965","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"fedoraproject:fedora","products":["fedoraproject:fedora","ruby-lang:ruby"],"type":"other","year":"2021"},"n_packages":7,"n_references":3,"next":{"headline":"Tempfile on Windows path traversal vulnerability","id":"CVE-2021-28966"},"packages":[{"ecosystem":"Bitnami","fixed":["2.6.7","2.7.3","3.0.1"],"introduced":["0","2.7.0","3.0.0"],"last_affected":[],"package":"ruby","purl":"pkg:bitnami/ruby","source":"BIT-ruby-2021-28965"},{"ecosystem":"Bitnami","fixed":["2.6.7","2.7.3","3.0.1"],"introduced":["0","2.7.0","3.0.0"],"last_affected":[],"package":"ruby-min","purl":"pkg:bitnami/ruby-min","source":"BIT-ruby-min-2021-28965"},{"ecosystem":"RubyGems","fixed":["3.2.5"],"introduced":["0"],"last_affected":[],"package":"rexml","purl":null,"source":"GHSA-8cr8-4vfw-mr7h"},{"ecosystem":"RubyGems","fixed":["3.2.5"],"introduced":["0"],"last_affected":[],"package":"rexml","purl":"pkg:gem/rexml","source":"GHSA-8cr8-4vfw-mr7h"},{"ecosystem":"SUSE:Linux Enterprise Micro 5.0","fixed":["2.5.9-4.17.1"],"introduced":["0"],"last_affected":[],"package":"ruby2.5","purl":"pkg:rpm/suse/ruby2.5\u0026distro=SUSE%20Linux%20Enterprise%20Micro%205.0","source":"SUSE-SU-2021:1280-1"},{"ecosystem":"SUSE:Linux Enterprise Module for Basesystem 15 SP2","fixed":["2.5.9-4.17.1"],"introduced":["0"],"last_affected":[],"package":"ruby2.5","purl":"pkg:rpm/suse/ruby2.5\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Basesystem%2015%20SP2","source":"SUSE-SU-2021:1280-1"},{"ecosystem":"openSUSE:Leap 15.2","fixed":["2.5.9-lp152.2.6.1"],"introduced":["0"],"last_affected":[],"package":"ruby2.5","purl":"pkg:rpm/opensuse/ruby2.5\u0026distro=openSUSE%20Leap%2015.2","source":"openSUSE-SU-2021:0607-1"}],"prev":{"headline":"Race condition in n/a","id":"CVE-2021-28964"},"products":["n/a"],"published":"2021-04-21","related":[{"cvss_score":9.8,"headline":"PHP-CGI OS Command Injection","id":"CVE-2024-4577","kev_date_added":"2024-06-12","published":"2024-06-09"},{"cvss_score":9.8,"headline":"Grafana Authentication Bypass","id":"CVE-2021-39226","kev_date_added":"2022-08-25","published":"2021-10-05"},{"cvss_score":9.8,"headline":"VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow","id":"CVE-2019-5544","kev_date_added":"2021-11-03","published":"2019-12-06"},{"cvss_score":9.6,"headline":"Google Chromium V8 Type Confusion","id":"CVE-2024-4947","kev_date_added":"2024-05-20","published":"2024-05-15"},{"cvss_score":9.6,"headline":"Google Chromium Visuals Use-After-Free","id":"CVE-2024-4671","kev_date_added":"2024-05-13","published":"2024-05-09"},{"cvss_score":9.6,"headline":"Google Chromium Mojo Insufficient Data Validation","id":"CVE-2022-3075","kev_date_added":"2022-09-08","published":"2022-09-26"},{"cvss_score":9.6,"headline":"Google Chromium Indexed DB API Use-After-Free","id":"CVE-2021-30633","kev_date_added":"2021-11-03","published":"2021-10-08"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["n/a"]},"summary":"An attacker can cause data corruption by exploiting improper XML round-trip handling in the REXML library, leading to incorrect document serialization.","url":"https://insights.sbomify.com/CVE-2021-28965/"}