# CVE-2021-28966: Tempfile on Windows path traversal vulnerability

> A remote attacker can exploit a path traversal vulnerability in Ruby's TmpDir handling on Windows to read or modify arbitrary files.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Jul 2021
- **Updated:** 3 Aug 2024
- **Also known as:** ALPINE-CVE-2021-28966, BIT-ruby-2021-28966, BIT-ruby-min-2021-28966, CLEANSTART-2026-YW10276, GHSA-46f2-3v63-3xrp, JLSEC-2026-1283

## What is CVE-2021-28966?

CVE-2021-28966 is a high-severity path traversal vulnerability in Ruby-Lang Ruby, published on 27 Jul 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Ruby through 3.0 on Windows, a remote attacker can submit a crafted path when a Web application handles a parameter with TmpDir.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2021-28966?

4 open source packages ship an affected version, including ruby, ruby-min and tmpdir. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ruby` | Bitnami | All versions | 2.7.3, 3.0.1 |
| `ruby-min` | Bitnami | All versions | 2.7.3, 3.0.1 |
| `tmpdir` | RubyGems | All versions | 0.1.2 |
| `tmpdir` | RubyGems | All versions | 0.1.2 |

Products: Ruby-Lang Ruby.

## How do I fix CVE-2021-28966?

Upgrade ruby to a fixed version for your release line: 2.7.3 or 3.0.1.

## Is CVE-2021-28966 being exploited?

There is no known exploitation of CVE-2021-28966 in the wild and no public exploit code.

## Other vulnerabilities in Ruby-Lang Ruby

- [CVE-2009-4124](https://insights.sbomify.com/CVE-2009-4124/): Memory corruption in n/a (critical 10.0)
- [CVE-2022-28738](https://insights.sbomify.com/CVE-2022-28738/): Use after free in n/a (critical 9.8)
- [CVE-2011-4121](https://insights.sbomify.com/CVE-2011-4121/): Weak cryptography in OpenSSL extension of Ruby (Git trunk) (critical 9.8)
- [CVE-2017-17790](https://insights.sbomify.com/CVE-2017-17790/): Command injection in n/a (critical 9.8)
- [CVE-2017-11465](https://insights.sbomify.com/CVE-2017-11465/): Memory corruption in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-28966 and fix it if it is affected.

What it is: CVE-2021-28966 is a high-severity path traversal vulnerability in Ruby-Lang Ruby, published on 27 Jul 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-28966 in the wild and no public exploit code.

Affected packages and fixed versions:
- ruby (Bitnami): affected all versions; fixed in 2.7.3, 3.0.1
- ruby-min (Bitnami): affected all versions; fixed in 2.7.3, 3.0.1
- tmpdir (RubyGems): affected all versions; fixed in 0.1.2
- tmpdir (RubyGems): affected all versions; fixed in 0.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-28966/ (Markdown: https://insights.sbomify.com/CVE-2021-28966/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-28966
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-28966
- OSV: https://osv.dev/vulnerability/CVE-2021-28966

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-28966/
Summaries are generated and may contain mistakes; the official description above is the record.
