# CVE-2021-29046: Liferay Portal and Liferay DXP Vulnerable to Cross-Site Scripting (XSS) via Asset Module Parameter

> Remote attackers can inject arbitrary web script or HTML into the Asset module's category selector, potentially compromising user sessions.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 17 May 2021
- **Updated:** 9 Jul 2026
- **Also known as:** GHSA-9g57-m5vf-qp73

## What is CVE-2021-29046?

CVE-2021-29046 is a medium-severity cross-site scripting vulnerability in Liferay Liferay Portal, published on 17 May 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cross-site scripting (XSS) vulnerability in the Asset module's category selector input field in Liferay Portal 7.3.5 and Liferay DXP 7.3 before fix pack 1, allows remote attackers to inject arbitrary web script or HTML via the _com_liferay_asset_categories_admin_web_portlet_AssetCategoriesAdminPortlet_title parameter.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-29046?

4 open source packages ship an affected version, including com.liferay.portal:release.dxp.bom and com.liferay.portal:release.portal.bom. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.liferay.portal:release.dxp.bom` | Maven | From 7.3.10.fp0 | 7.3.10.fp1 |
| `com.liferay.portal:release.dxp.bom` | Maven | From 7.3.10.fp0 | 7.3.10.fp1 |
| `com.liferay.portal:release.portal.bom` | Maven | All versions | None |
| `com.liferay.portal:release.portal.bom` | Maven | All versions | None |

Products: Liferay Dxp, Liferay Liferay Portal.

## How do I fix CVE-2021-29046?

Upgrade com.liferay.portal:release.dxp.bom to 7.3.10.fp1 or later.

## Is CVE-2021-29046 being exploited?

There is no known exploitation of CVE-2021-29046 in the wild and no public exploit code.

## Other vulnerabilities in Liferay Liferay Portal

- [CVE-2022-42120](https://insights.sbomify.com/CVE-2022-42120/): Liferay Portal and Liferay DXP Vulnerable to SQL Injection via the Fragment Module (critical 9.8)
- [CVE-2022-42122](https://insights.sbomify.com/CVE-2022-42122/): Liferay Portal and Liferay DXP Vulnerable to SQL Injection via Friendly URL Module (critical 9.8)
- [CVE-2023-35030](https://insights.sbomify.com/CVE-2023-35030/): Liferay Portal and Liferay DXP Vulnerable to CSRF via the Layout Module (high 8.8)
- [CVE-2021-29053](https://insights.sbomify.com/CVE-2021-29053/): Liferay Portal and Liferay DXP Vulnerable to Multiple SQL Injections (high 8.8)
- [CVE-2021-33321](https://insights.sbomify.com/CVE-2021-33321/): Liferay Portal and Liferay DXP insecure default configuration (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-29046 and fix it if it is affected.

What it is: CVE-2021-29046 is a medium-severity cross-site scripting vulnerability in Liferay Liferay Portal, published on 17 May 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-29046 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.liferay.portal:release.dxp.bom (Maven): affected from 7.3.10.fp0; fixed in 7.3.10.fp1
- com.liferay.portal:release.dxp.bom (Maven): affected from 7.3.10.fp0; fixed in 7.3.10.fp1
- com.liferay.portal:release.portal.bom (Maven): affected all versions; no fix listed
- com.liferay.portal:release.portal.bom (Maven): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-29046/ (Markdown: https://insights.sbomify.com/CVE-2021-29046/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-29046
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-29046
- OSV: https://osv.dev/vulnerability/CVE-2021-29046

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-29046/
Summaries are generated and may contain mistakes; the official description above is the record.
