{"answers":{"affected":"4 open source packages ship an affected version, including com.liferay.portal:com.liferay.portal.impl and com.liferay.portal:release.dxp.bom.","exploited":"There is no known exploitation of CVE-2021-29050 in the wild and no public exploit code.","fix":"Upgrade com.liferay.portal:com.liferay.portal.impl to 5.25.0 or later.","what":"CVE-2021-29050 is a high-severity vulnerability in n/a, published on 20 Feb 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-29050 and fix it if it is affected.\n\nWhat it is: CVE-2021-29050 is a high-severity vulnerability in n/a, published on 20 Feb 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2021-29050 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- com.liferay.portal:com.liferay.portal.impl (Maven): affected all versions; fixed in 5.25.0\n- com.liferay.portal:com.liferay.portal.impl (Maven): affected all versions; fixed in 5.25.0\n- com.liferay.portal:release.dxp.bom (Maven): affected from 7.2.0; fixed in 7.2.10.fp11\n- com.liferay.portal:release.dxp.bom (Maven): affected from 7.2.0; fixed in 7.2.10.fp11\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-29050/ (Markdown: https://insights.sbomify.com/CVE-2021-29050/index.md)","id":"CVE-2021-29050","markdown":"https://insights.sbomify.com/CVE-2021-29050/index.md","name":"CVE-2021-29050","record":{"aliases":["GHSA-mh9r-9pcx-rx55"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Liferay Portal","requires_auth":"none","summary":"Attackers can force users to accept site terms of use via CSRF, requiring an upgrade to Liferay Portal or DXP.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[],"cvss":{"score":8.8,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"Cross-Site Request Forgery (CSRF) vulnerability in the terms of use page in Liferay Portal before 7.3.6, and Liferay DXP 7.3 before service pack 1, 7.2 before fix pack 11 allows remote attackers to accept the site's terms of use via social engineering and enticing the user to visit a malicious page.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Liferay Portal and Liferay DXP Vulnerable to Cross-Site Request Forgery in Terms of Use Page","id":"CVE-2021-29050","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"csrf","year":"2021"},"n_packages":4,"n_references":1,"next":{"headline":"Liferay Portal and Liferay DXP Vulnerable to Cross-Site Scripting (XSS) in Asset Publisher App","id":"CVE-2021-29051"},"packages":[{"ecosystem":"Maven","fixed":["5.25.0"],"introduced":["0"],"last_affected":[],"package":"com.liferay.portal:com.liferay.portal.impl","purl":null,"source":"GHSA-mh9r-9pcx-rx55"},{"ecosystem":"Maven","fixed":["5.25.0"],"introduced":["0"],"last_affected":[],"package":"com.liferay.portal:com.liferay.portal.impl","purl":"pkg:maven/com.liferay.portal/com.liferay.portal.impl","source":"GHSA-mh9r-9pcx-rx55"},{"ecosystem":"Maven","fixed":["7.2.10.fp11"],"introduced":["7.2.0"],"last_affected":[],"package":"com.liferay.portal:release.dxp.bom","purl":null,"source":"GHSA-mh9r-9pcx-rx55"},{"ecosystem":"Maven","fixed":["7.2.10.fp11"],"introduced":["7.2.0"],"last_affected":[],"package":"com.liferay.portal:release.dxp.bom","purl":"pkg:maven/com.liferay.portal/release.dxp.bom","source":"GHSA-mh9r-9pcx-rx55"}],"prev":{"headline":"Liferay DXP Vulnerable to Cross-Site Scripting (XSS) via the currentURL Parameter","id":"CVE-2021-29049"},"products":["n/a"],"published":"2024-02-20","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-04-24","vendors":["n/a"]},"summary":"Attackers can force users to accept site terms of use via CSRF, requiring an upgrade to Liferay Portal or DXP.","url":"https://insights.sbomify.com/CVE-2021-29050/"}