# CVE-2021-29050: Liferay Portal and Liferay DXP Vulnerable to Cross-Site Request Forgery in Terms of Use Page

> Attackers can force users to accept site terms of use via CSRF, requiring an upgrade to Liferay Portal or DXP.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 20 Feb 2024
- **Updated:** 24 Apr 2025
- **Also known as:** GHSA-mh9r-9pcx-rx55

## What is CVE-2021-29050?

CVE-2021-29050 is a high-severity vulnerability in n/a, published on 20 Feb 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cross-Site Request Forgery (CSRF) vulnerability in the terms of use page in Liferay Portal before 7.3.6, and Liferay DXP 7.3 before service pack 1, 7.2 before fix pack 11 allows remote attackers to accept the site's terms of use via social engineering and enticing the user to visit a malicious page.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2021-29050?

4 open source packages ship an affected version, including com.liferay.portal:com.liferay.portal.impl and com.liferay.portal:release.dxp.bom.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.liferay.portal:com.liferay.portal.impl` | Maven | All versions | 5.25.0 |
| `com.liferay.portal:com.liferay.portal.impl` | Maven | All versions | 5.25.0 |
| `com.liferay.portal:release.dxp.bom` | Maven | From 7.2.0 | 7.2.10.fp11 |
| `com.liferay.portal:release.dxp.bom` | Maven | From 7.2.0 | 7.2.10.fp11 |

## How do I fix CVE-2021-29050?

Upgrade com.liferay.portal:com.liferay.portal.impl to 5.25.0 or later.

## Is CVE-2021-29050 being exploited?

There is no known exploitation of CVE-2021-29050 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-29050 and fix it if it is affected.

What it is: CVE-2021-29050 is a high-severity vulnerability in n/a, published on 20 Feb 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-29050 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.liferay.portal:com.liferay.portal.impl (Maven): affected all versions; fixed in 5.25.0
- com.liferay.portal:com.liferay.portal.impl (Maven): affected all versions; fixed in 5.25.0
- com.liferay.portal:release.dxp.bom (Maven): affected from 7.2.0; fixed in 7.2.10.fp11
- com.liferay.portal:release.dxp.bom (Maven): affected from 7.2.0; fixed in 7.2.10.fp11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-29050/ (Markdown: https://insights.sbomify.com/CVE-2021-29050/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-29050
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-29050
- OSV: https://osv.dev/vulnerability/CVE-2021-29050

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-29050/
Summaries are generated and may contain mistakes; the official description above is the record.
