# CVE-2021-29060: Regular Expression Denial of Service (ReDOS)

> Attackers can cause a denial of service in applications using the Color-String library by providing crafted invalid HWB strings that trigger excessive CPU usage.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Jun 2021
- **Updated:** 3 Aug 2024
- **Also known as:** CLSA-2026-1774570927, DEBIAN-CVE-2021-29060, GHSA-257v-vj4p-3w2h, UBUNTU-CVE-2021-29060

## What is CVE-2021-29060?

CVE-2021-29060 is a medium-severity denial of service vulnerability in n/a, published on 21 Jun 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A Regular Expression Denial of Service (ReDOS) vulnerability was discovered in Color-String version 1.5.5 and below which occurs when the application is provided and checks a crafted invalid HWB string.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2021-29060?

2 open source packages ship an affected version, including color-string. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `color-string` | npm | All versions | 1.5.5 |
| `color-string` | npm | All versions | 1.5.5 |

Products: Color-String Project Color-String.

## How do I fix CVE-2021-29060?

Upgrade color-string to 1.5.5 or later.

## Is CVE-2021-29060 being exploited?

There is no known exploitation of CVE-2021-29060 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-29060 and fix it if it is affected.

What it is: CVE-2021-29060 is a medium-severity denial of service vulnerability in n/a, published on 21 Jun 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-29060 in the wild and no public exploit code.

Affected packages and fixed versions:
- color-string (npm): affected all versions; fixed in 1.5.5
- color-string (npm): affected all versions; fixed in 1.5.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-29060/ (Markdown: https://insights.sbomify.com/CVE-2021-29060/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-29060
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-29060
- OSV: https://osv.dev/vulnerability/CVE-2021-29060

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-29060/
Summaries are generated and may contain mistakes; the official description above is the record.
