# CVE-2021-29063: ReDOS in Mpmath

> An attacker can cause a denial of service in applications using the Mpmath library by triggering a Regular Expression Denial of Service via the mpmathify function.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Jun 2021
- **Updated:** 3 Aug 2024
- **Also known as:** DEBIAN-CVE-2021-29063, GHSA-f865-m6cq-j9vx, MGASA-2021-0479, PYSEC-2021-427, UBUNTU-CVE-2021-29063, USN-7160-1, openSUSE-SU-2024:13280-1, openSUSE-SU-2026:12018-1

## What is CVE-2021-29063?

CVE-2021-29063 is a high-severity denial of service vulnerability in Fedoraproject Fedora, published on 21 Jun 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A Regular Expression Denial of Service (ReDOS) vulnerability was discovered in Mpmath v1.0.0 through v1.2.1 when the mpmathify function is called.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2021-29063?

3 open source packages ship an affected version, including mpmath. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mpmath` | PyPI | All versions | 1.3.0 |
| `mpmath` | PyPI | All versions | 1.3.0 |
| `mpmath` | PyPI | All versions | 1.3.0 |
| `python-mpmath` | openSUSE:Tumbleweed | All versions | 1.3.0-3.4 |

Products: Fedoraproject Fedora, Mpmath Mpmath.

## How do I fix CVE-2021-29063?

Upgrade mpmath to 1.3.0 or later.

## Is CVE-2021-29063 being exploited?

There is no known exploitation of CVE-2021-29063 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-29063 and fix it if it is affected.

What it is: CVE-2021-29063 is a high-severity denial of service vulnerability in Fedoraproject Fedora, published on 21 Jun 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-29063 in the wild and no public exploit code.

Affected packages and fixed versions:
- mpmath (PyPI): affected all versions; fixed in 1.3.0
- mpmath (PyPI): affected all versions; fixed in 1.3.0
- mpmath (PyPI): affected all versions; fixed in 1.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-29063/ (Markdown: https://insights.sbomify.com/CVE-2021-29063/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-29063
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-29063
- OSV: https://osv.dev/vulnerability/CVE-2021-29063

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-29063/
Summaries are generated and may contain mistakes; the official description above is the record.
