{"answers":{"affected":"2 open source packages ship an affected version, including @ronomon/opened. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-29300 in the wild and no public exploit code.","fix":"Upgrade @ronomon/opened to 1.5.2 or later.","what":"CVE-2021-29300 is a critical command injection vulnerability in n/a, published on 24 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-29300 and fix it if it is affected.\n\nWhat it is: CVE-2021-29300 is a critical command injection vulnerability in n/a, published on 24 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-29300 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @ronomon/opened (npm): affected all versions; fixed in 1.5.2\n- @ronomon/opened (npm): affected all versions; fixed in 1.5.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-29300/ (Markdown: https://insights.sbomify.com/CVE-2021-29300/index.md)","id":"CVE-2021-29300","markdown":"https://insights.sbomify.com/CVE-2021-29300/index.md","name":"CVE-2021-29300","record":{"aliases":["GHSA-fg5w-w99f-rj6w"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js library","requires_auth":"none","summary":"A remote attacker can execute arbitrary system commands via untrusted input in the @ronomon/opened library.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"opened","vendor":"ronomon"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"The @ronomon/opened library before 1.5.2 is vulnerable to a command injection vulnerability which would allow a remote attacker to execute commands on the system if the library was used with untrusted input.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Command Injection in @ronomon/opened","id":"CVE-2021-29300","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"command_injection","year":"2021"},"n_packages":2,"n_references":2,"next":{"headline":"Memory corruption in n/a","id":"CVE-2021-29302"},"packages":[{"ecosystem":"npm","fixed":["1.5.2"],"introduced":["0"],"last_affected":[],"package":"@ronomon/opened","purl":null,"source":"GHSA-fg5w-w99f-rj6w"},{"ecosystem":"npm","fixed":["1.5.2"],"introduced":["0"],"last_affected":[],"package":"@ronomon/opened","purl":"pkg:npm/%40ronomon/opened","source":"GHSA-fg5w-w99f-rj6w"}],"prev":{"headline":"Denial of service in n/a","id":"CVE-2021-29298"},"products":["n/a"],"published":"2021-05-24","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["n/a"]},"summary":"A remote attacker can execute arbitrary system commands via untrusted input in the @ronomon/opened library.","url":"https://insights.sbomify.com/CVE-2021-29300/"}