{"answers":{"affected":"2 open source packages ship an affected version, including @rkesters/gnuplot. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-29369 in the wild and no public exploit code.","fix":"Upgrade @rkesters/gnuplot to 0.1.1 or later.","what":"CVE-2021-29369 is a critical command injection vulnerability in n/a, published on 3 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-29369 and fix it if it is affected.\n\nWhat it is: CVE-2021-29369 is a critical command injection vulnerability in n/a, published on 3 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-29369 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @rkesters/gnuplot (npm): affected all versions; fixed in 0.1.1\n- @rkesters/gnuplot (npm): affected all versions; fixed in 0.1.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-29369/ (Markdown: https://insights.sbomify.com/CVE-2021-29369/index.md)","id":"CVE-2021-29369","markdown":"https://insights.sbomify.com/CVE-2021-29369/index.md","name":"CVE-2021-29369","record":{"aliases":["GHSA-f2jw-pr2c-9x96"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js gnuplot library","requires_auth":"none","summary":"An attacker can execute arbitrary code by injecting shell metacharacters into Gnuplot commands within the Node.js gnuplot library.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"gnuplot","vendor":"gnuplot_project"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"The gnuplot package prior to version 0.1.0 for Node.js allows code execution via shell metacharacters in Gnuplot commands.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Code injection in @rkesters/gnuplot","id":"CVE-2021-29369","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"command_injection","year":"2021"},"n_packages":2,"n_references":2,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2021-29370"},"packages":[{"ecosystem":"npm","fixed":["0.1.1"],"introduced":["0"],"last_affected":[],"package":"@rkesters/gnuplot","purl":null,"source":"GHSA-f2jw-pr2c-9x96"},{"ecosystem":"npm","fixed":["0.1.1"],"introduced":["0"],"last_affected":[],"package":"@rkesters/gnuplot","purl":"pkg:npm/%40rkesters/gnuplot","source":"GHSA-f2jw-pr2c-9x96"}],"prev":{"headline":"Auth bypass in n/a","id":"CVE-2021-29368"},"products":["n/a"],"published":"2021-05-03","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["n/a"]},"summary":"An attacker can execute arbitrary code by injecting shell metacharacters into Gnuplot commands within the Node.js gnuplot library.","url":"https://insights.sbomify.com/CVE-2021-29369/"}