# CVE-2021-29369: Code injection in @rkesters/gnuplot

> An attacker can execute arbitrary code by injecting shell metacharacters into Gnuplot commands within the Node.js gnuplot library.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 May 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-f2jw-pr2c-9x96

## What is CVE-2021-29369?

CVE-2021-29369 is a critical command injection vulnerability in n/a, published on 3 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The gnuplot package prior to version 0.1.0 for Node.js allows code execution via shell metacharacters in Gnuplot commands.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2021-29369?

2 open source packages ship an affected version, including @rkesters/gnuplot. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@rkesters/gnuplot` | npm | All versions | 0.1.1 |
| `@rkesters/gnuplot` | npm | All versions | 0.1.1 |

Products: Gnuplot Project Gnuplot.

## How do I fix CVE-2021-29369?

Upgrade @rkesters/gnuplot to 0.1.1 or later.

## Is CVE-2021-29369 being exploited?

There is no known exploitation of CVE-2021-29369 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-29369 and fix it if it is affected.

What it is: CVE-2021-29369 is a critical command injection vulnerability in n/a, published on 3 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-29369 in the wild and no public exploit code.

Affected packages and fixed versions:
- @rkesters/gnuplot (npm): affected all versions; fixed in 0.1.1
- @rkesters/gnuplot (npm): affected all versions; fixed in 0.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-29369/ (Markdown: https://insights.sbomify.com/CVE-2021-29369/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-29369
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-29369
- OSV: https://osv.dev/vulnerability/CVE-2021-29369

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-29369/
Summaries are generated and may contain mistakes; the official description above is the record.
