CVE-2021-29428 Local privilege escalation through system temporary directory

High 8.8 Published Updated

Local attackers can escalate privileges via race conditions in Gradle's temporary directory handling on Unix systems lacking sticky bits.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2021-29428?

CVE-2021-29428 is a high-severity vulnerability in gradle, published on 13 Apr 2021. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

In Gradle before version 7.0, on Unix-like systems, the system temporary directory can be created with open permissions that allow multiple users to create and delete files within it. Gradle builds could be vulnerable to a local privilege escalation from an attacker quickly deleting and recreating files in the system temporary directory. This vulnerability impacted builds using precompiled script plugins written in Kotlin DSL and tests for Gradle plugins written using ProjectBuilder or TestKit. If you are on Windows or modern versions of macOS, you are not vulnerable. If you are on a Unix-like operating system with the "sticky" bit set on your system temporary directory, you are not vulnerable. The problem has been patched and released with Gradle 7.0. As a workaround, on Unix-like operating systems, ensure that the "sticky" bit is set. This only allows the original user (or root) to delete a file. If you are unable to change the permissions of the system temporary directory, you can move the Java temporary directory by setting the System Property `java.io.tmpdir`. The new path needs to limit permissions to the build user only. For additional details refer to the referenced GitHub Security Advisory.

Weakness: CWE-379, CWE-378

Which versions are affected by CVE-2021-29428?

1 open source package ship an affected version, including gradle. It affects 2 products.

PackageAffectedFixed in
gradle BitnamiAll versions7.0.0
Linux distribution packages (12)
gradle SUSE:Enterprise Storage 7All versions4.4.1-150200.3.7.1
gradle SUSE:Enterprise Storage 7.1All versions4.4.1-150200.3.7.1
gradle SUSE:Linux Enterprise High Performance Computing 15 SP2-LTSSAll versions4.4.1-150200.3.7.1
gradle SUSE:Linux Enterprise High Performance Computing 15 SP3-ESPOSAll versions4.4.1-150200.3.7.1
gradle SUSE:Linux Enterprise High Performance Computing 15 SP3-LTSSAll versions4.4.1-150200.3.7.1
gradle SUSE:Linux Enterprise Module for Development Tools 15 SP4All versions4.4.1-150200.3.7.1
gradle SUSE:Linux Enterprise Real Time 15 SP3All versions4.4.1-150200.3.7.1
gradle SUSE:Linux Enterprise Server 15 SP2-LTSSAll versions4.4.1-150200.3.7.1
gradle SUSE:Linux Enterprise Server 15 SP3-LTSSAll versions4.4.1-150200.3.7.1
gradle SUSE:Linux Enterprise Server for SAP Applications 15 SP2All versions4.4.1-150200.3.7.1
gradle SUSE:Linux Enterprise Server for SAP Applications 15 SP3All versions4.4.1-150200.3.7.1
gradle openSUSE:Leap 15.4All versions4.4.1-150200.3.7.1

Products include Gradle Gradle, Quarkus Quarkus.

How do I fix CVE-2021-29428?

Upgrade gradle to 7.0.0 or later.

Is CVE-2021-29428 being exploited?

There is no known exploitation of CVE-2021-29428 in the wild and no public exploit code.

Sources

Also known as BIT-gradle-2021-29428, DEBIAN-CVE-2021-29428, GHSA-89qm-pxvm-p336, SUSE-SU-2023:1867-1, UBUNTU-CVE-2021-29428.

Is CVE-2021-29428 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free