# CVE-2021-29428: Local privilege escalation through system temporary directory

> Local attackers can escalate privileges via race conditions in Gradle's temporary directory handling on Unix systems lacking sticky bits.

- **Severity:** High 8.8 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Apr 2021
- **Updated:** 8 Oct 2026
- **Also known as:** BIT-gradle-2021-29428, DEBIAN-CVE-2021-29428, GHSA-89qm-pxvm-p336, SUSE-SU-2023:1867-1, UBUNTU-CVE-2021-29428

## What is CVE-2021-29428?

CVE-2021-29428 is a high-severity vulnerability in gradle, published on 13 Apr 2021. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

In Gradle before version 7.0, on Unix-like systems, the system temporary directory can be created with open permissions that allow multiple users to create and delete files within it. Gradle builds could be vulnerable to a local privilege escalation from an attacker quickly deleting and recreating files in the system temporary directory. This vulnerability impacted builds using precompiled script plugins written in Kotlin DSL and tests for Gradle plugins written using ProjectBuilder or TestKit. If you are on Windows or modern versions of macOS, you are not vulnerable. If you are on a Unix-like operating system with the "sticky" bit set on your system temporary directory, you are not vulnerable. The problem has been patched and released with Gradle 7.0. As a workaround, on Unix-like operating systems, ensure that the "sticky" bit is set. This only allows the original user (or root) to delete a file. If you are unable to change the permissions of the system temporary directory, you can move the Java temporary directory by setting the System Property `java.io.tmpdir`. The new path needs to limit permissions to the build user only. For additional details refer to the referenced GitHub Security Advisory.

Weakness: CWE-379 (Creation of Temporary File in Directory with Insecure Permissions), CWE-378 (Creation of Temporary File With Insecure Permissions)

## Which versions are affected by CVE-2021-29428?

1 open source package ship an affected version, including gradle. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gradle` | Bitnami | All versions | 7.0.0 |
| `gradle` | SUSE:Enterprise Storage 7 | All versions | 4.4.1-150200.3.7.1 |
| `gradle` | SUSE:Enterprise Storage 7.1 | All versions | 4.4.1-150200.3.7.1 |
| `gradle` | SUSE:Linux Enterprise High Performance Computing 15 SP2-LTSS | All versions | 4.4.1-150200.3.7.1 |
| `gradle` | SUSE:Linux Enterprise High Performance Computing 15 SP3-ESPOS | All versions | 4.4.1-150200.3.7.1 |
| `gradle` | SUSE:Linux Enterprise High Performance Computing 15 SP3-LTSS | All versions | 4.4.1-150200.3.7.1 |
| `gradle` | SUSE:Linux Enterprise Module for Development Tools 15 SP4 | All versions | 4.4.1-150200.3.7.1 |
| `gradle` | SUSE:Linux Enterprise Real Time 15 SP3 | All versions | 4.4.1-150200.3.7.1 |
| `gradle` | SUSE:Linux Enterprise Server 15 SP2-LTSS | All versions | 4.4.1-150200.3.7.1 |
| `gradle` | SUSE:Linux Enterprise Server 15 SP3-LTSS | All versions | 4.4.1-150200.3.7.1 |
| `gradle` | SUSE:Linux Enterprise Server for SAP Applications 15 SP2 | All versions | 4.4.1-150200.3.7.1 |
| `gradle` | SUSE:Linux Enterprise Server for SAP Applications 15 SP3 | All versions | 4.4.1-150200.3.7.1 |
| `gradle` | openSUSE:Leap 15.4 | All versions | 4.4.1-150200.3.7.1 |

Products: Gradle Gradle, Quarkus Quarkus.

## How do I fix CVE-2021-29428?

Upgrade gradle to 7.0.0 or later.

## Is CVE-2021-29428 being exploited?

There is no known exploitation of CVE-2021-29428 in the wild and no public exploit code.

## Other vulnerabilities in gradle

- [CVE-2019-15052](https://insights.sbomify.com/CVE-2019-15052/): Information disclosure in n/a (critical 9.8)
- [CVE-2016-6199](https://insights.sbomify.com/CVE-2016-6199/): Deserialization in n/a (critical 9.8)
- [CVE-2026-22816](https://insights.sbomify.com/CVE-2026-22816/): Gradle fails to disable repositories which can expose builds to malicious artifacts (high 8.6)
- [CVE-2026-22865](https://insights.sbomify.com/CVE-2026-22865/): Gradle's failure to disable repositories failing to answer can expose builds to malicious artifacts (high 8.6)
- [CVE-2021-41588](https://insights.sbomify.com/CVE-2021-41588/): Deserialization in n/a (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-29428 and fix it if it is affected.

What it is: CVE-2021-29428 is a high-severity vulnerability in gradle, published on 13 Apr 2021. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-29428 in the wild and no public exploit code.

Affected packages and fixed versions:
- gradle (Bitnami): affected all versions; fixed in 7.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-29428/ (Markdown: https://insights.sbomify.com/CVE-2021-29428/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-29428
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-29428
- OSV: https://osv.dev/vulnerability/CVE-2021-29428

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-29428/
Summaries are generated and may contain mistakes; the official description above is the record.
