# CVE-2021-29429: Information disclosure through temporary directory permissions

> Local attackers can read sensitive files downloaded by Gradle due to insecure temporary directory permissions, exposing data to other users on the system.

- **Severity:** Medium 4.0 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Apr 2021
- **Updated:** 8 Oct 2026
- **Also known as:** BIT-gradle-2021-29429, DEBIAN-CVE-2021-29429, GHSA-fp8h-qmr5-j4c8

## What is CVE-2021-29429?

CVE-2021-29429 is a medium-severity vulnerability in gradle, published on 12 Apr 2021. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

In Gradle before version 7.0, files created with open permissions in the system temporary directory can allow an attacker to access information downloaded by Gradle. Some builds could be vulnerable to a local information disclosure. Remote files accessed through TextResourceFactory are downloaded into the system temporary directory first. Sensitive information contained in these files can be exposed to other local users on the same system. If you do not use the `TextResourceFactory` API, you are not vulnerable. As of Gradle 7.0, uses of the system temporary directory have been moved to the Gradle User Home directory. By default, this directory is restricted to the user running the build. As a workaround, set a more restrictive umask that removes read access to other users. When files are created in the system temporary directory, they will not be accessible to other users. If you are unable to change your system's umask, you can move the Java temporary directory by setting the System Property `java.io.tmpdir`. The new path needs to limit permissions to the build user only.

Weakness: CWE-377 (DEPRECATED: Insecure Temporary File)

## Which versions are affected by CVE-2021-29429?

1 open source package ship an affected version, including gradle. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gradle` | Bitnami | All versions | 7.0.0 |

Products: Gradle Gradle, Quarkus Quarkus.

## How do I fix CVE-2021-29429?

Upgrade gradle to 7.0.0 or later.

## Is CVE-2021-29429 being exploited?

There is no known exploitation of CVE-2021-29429 in the wild and no public exploit code.

## Other vulnerabilities in gradle

- [CVE-2019-15052](https://insights.sbomify.com/CVE-2019-15052/): Information disclosure in n/a (critical 9.8)
- [CVE-2016-6199](https://insights.sbomify.com/CVE-2016-6199/): Deserialization in n/a (critical 9.8)
- [CVE-2021-29428](https://insights.sbomify.com/CVE-2021-29428/): Local privilege escalation through system temporary directory (high 8.8)
- [CVE-2026-22816](https://insights.sbomify.com/CVE-2026-22816/): Gradle fails to disable repositories which can expose builds to malicious artifacts (high 8.6)
- [CVE-2026-22865](https://insights.sbomify.com/CVE-2026-22865/): Gradle's failure to disable repositories failing to answer can expose builds to malicious artifacts (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-29429 and fix it if it is affected.

What it is: CVE-2021-29429 is a medium-severity vulnerability in gradle, published on 12 Apr 2021. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-29429 in the wild and no public exploit code.

Affected packages and fixed versions:
- gradle (Bitnami): affected all versions; fixed in 7.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-29429/ (Markdown: https://insights.sbomify.com/CVE-2021-29429/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-29429
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-29429
- OSV: https://osv.dev/vulnerability/CVE-2021-29429

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-29429/
Summaries are generated and may contain mistakes; the official description above is the record.
