# CVE-2021-29430: Denial of service attack via memory exhaustion

> Attackers can cause denial of service in Sydent by sending oversized HTTP requests or responses, exhausting server memory.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Apr 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-wmg4-8cp2-hpg9, PYSEC-2021-21

## What is CVE-2021-29430?

CVE-2021-29430 is a high-severity denial of service vulnerability in matrix-org sydent, published on 15 Apr 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Sydent is a reference Matrix identity server. Sydent does not limit the size of requests it receives from HTTP clients. A malicious user could send an HTTP request with a very large body, leading to memory exhaustion and denial of service. Sydent also does not limit response size for requests it makes to remote Matrix homeservers. A malicious homeserver could return a very large response, again leading to memory exhaustion and denial of service. This affects any server which accepts registration requests from untrusted clients. This issue has been patched by releases 89071a1, 0523511, f56eee3. As a workaround request sizes can be limited in an HTTP reverse-proxy. There are no known workarounds for the problem with overlarge responses.

Weakness: CWE-400 (Uncontrolled Resource Consumption), CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2021-29430?

3 open source packages ship an affected version, including matrix-sydent. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `matrix-sydent` | PyPI | All versions | 2.3.0 |
| `matrix-sydent` | PyPI | All versions | 2.3.0 |
| `matrix-sydent` | PyPI | All versions | 2.3.0 |

Products: Matrix Sydent.

## How do I fix CVE-2021-29430?

Upgrade matrix-sydent to 2.3.0 or later.

## Is CVE-2021-29430 being exploited?

There is no known exploitation of CVE-2021-29430 in the wild and no public exploit code.

## Other vulnerabilities in matrix-org sydent

- [CVE-2023-38686](https://insights.sbomify.com/CVE-2023-38686/): Sydent does not verify email server certificates (critical 9.3)
- [CVE-2021-29431](https://insights.sbomify.com/CVE-2021-29431/): SSRF in Sydent due to missing validation of hostnames (high 7.7)
- [CVE-2019-11842](https://insights.sbomify.com/CVE-2019-11842/): matrix-sydent and matrix-synapse Use Cryptographically Weak PRNG (high 7.5)
- [CVE-2019-11340](https://insights.sbomify.com/CVE-2019-11340/): Matrix Sydent mishandles emails (medium 5.9)
- [CVE-2021-29432](https://insights.sbomify.com/CVE-2021-29432/): Malicious users could control the content of invitation emails (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-29430 and fix it if it is affected.

What it is: CVE-2021-29430 is a high-severity denial of service vulnerability in matrix-org sydent, published on 15 Apr 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-29430 in the wild and no public exploit code.

Affected packages and fixed versions:
- matrix-sydent (PyPI): affected all versions; fixed in 2.3.0
- matrix-sydent (PyPI): affected all versions; fixed in 2.3.0
- matrix-sydent (PyPI): affected all versions; fixed in 2.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-29430/ (Markdown: https://insights.sbomify.com/CVE-2021-29430/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-29430
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-29430
- OSV: https://osv.dev/vulnerability/CVE-2021-29430

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-29430/
Summaries are generated and may contain mistakes; the official description above is the record.
