CVE-2021-29435 Cross-Site Request Forgery (CSRF) in trestle-auth
An attacker can bypass CSRF protection to modify protected data and admin credentials in Trestle admin sessions.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2021-29435?
CVE-2021-29435 is a high-severity vulnerability in TrestleAdmin trestle-auth, published on 13 Apr 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
trestle-auth is an authentication plugin for the Trestle admin framework. A vulnerability in trestle-auth versions 0.4.0 and 0.4.1 allows an attacker to create a form that will bypass Rails' built-in CSRF protection when submitted by a victim with a trestle-auth admin session. This potentially allows an attacker to alter protected data, including admin account credentials. The vulnerability has been fixed in trestle-auth 0.4.2 released to RubyGems.
Weakness: CWE-352
Which versions are affected by CVE-2021-29435?
2 open source packages ship an affected version, including trestle-auth. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
trestle-auth RubyGems | From 0.4.0 | 0.4.2 |
trestle-auth RubyGems | From 0.4.0 | 0.4.2 |
Products include Trestle-Auth Project Trestle-Auth.
How do I fix CVE-2021-29435?
Upgrade trestle-auth to 0.4.2 or later.
Is CVE-2021-29435 being exploited?
There is no known exploitation of CVE-2021-29435 in the wild and no public exploit code.
Sources
Also known as GHSA-h8hx-2c5r-32cf.