{"answers":{"affected":"2 open source packages ship an affected version, including trestle-auth. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-29435 in the wild and no public exploit code.","fix":"Upgrade trestle-auth to 0.4.2 or later.","what":"CVE-2021-29435 is a high-severity vulnerability in TrestleAdmin trestle-auth, published on 13 Apr 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-29435 and fix it if it is affected.\n\nWhat it is: CVE-2021-29435 is a high-severity vulnerability in TrestleAdmin trestle-auth, published on 13 Apr 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2021-29435 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- trestle-auth (RubyGems): affected from 0.4.0; fixed in 0.4.2\n- trestle-auth (RubyGems): affected from 0.4.0; fixed in 0.4.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-29435/ (Markdown: https://insights.sbomify.com/CVE-2021-29435/index.md)","id":"CVE-2021-29435","markdown":"https://insights.sbomify.com/CVE-2021-29435/index.md","name":"CVE-2021-29435","record":{"aliases":["GHSA-h8hx-2c5r-32cf"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_modify","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby authentication plugin","requires_auth":"none","summary":"An attacker can bypass CSRF protection to modify protected data and admin credentials in Trestle admin sessions.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"trestle-auth","vendor":"trestle-auth_project"}],"cvss":{"score":8.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"trestle-auth is an authentication plugin for the Trestle admin framework. A vulnerability in trestle-auth versions 0.4.0 and 0.4.1 allows an attacker to create a form that will bypass Rails' built-in CSRF protection when submitted by a victim with a trestle-auth admin session. This potentially allows an attacker to alter protected data, including admin account credentials. The vulnerability has been fixed in trestle-auth 0.4.2 released to RubyGems.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-Site Request Forgery (CSRF) in trestle-auth","id":"CVE-2021-29435","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"csrf","year":"2021"},"n_packages":2,"n_references":3,"next":{"headline":"Cross site request forgery vulnerability","id":"CVE-2021-29436"},"packages":[{"ecosystem":"RubyGems","fixed":["0.4.2"],"introduced":["0.4.0"],"last_affected":[],"package":"trestle-auth","purl":null,"source":"GHSA-h8hx-2c5r-32cf"},{"ecosystem":"RubyGems","fixed":["0.4.2"],"introduced":["0.4.0"],"last_affected":[],"package":"trestle-auth","purl":"pkg:gem/trestle-auth","source":"GHSA-h8hx-2c5r-32cf"}],"prev":{"headline":"Improper validation of URLs ('Cross-site Scripting') in Wagtail rich text fields","id":"CVE-2021-29434"},"products":["trestle-auth"],"published":"2021-04-13","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["TrestleAdmin"]},"summary":"An attacker can bypass CSRF protection to modify protected data and admin credentials in Trestle admin sessions.","url":"https://insights.sbomify.com/CVE-2021-29435/"}