# CVE-2021-29435: Cross-Site Request Forgery (CSRF) in trestle-auth

> An attacker can bypass CSRF protection to modify protected data and admin credentials in Trestle admin sessions.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 13 Apr 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-h8hx-2c5r-32cf

## What is CVE-2021-29435?

CVE-2021-29435 is a high-severity vulnerability in TrestleAdmin trestle-auth, published on 13 Apr 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

trestle-auth is an authentication plugin for the Trestle admin framework. A vulnerability in trestle-auth versions 0.4.0 and 0.4.1 allows an attacker to create a form that will bypass Rails' built-in CSRF protection when submitted by a victim with a trestle-auth admin session. This potentially allows an attacker to alter protected data, including admin account credentials. The vulnerability has been fixed in trestle-auth 0.4.2 released to RubyGems.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2021-29435?

2 open source packages ship an affected version, including trestle-auth. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `trestle-auth` | RubyGems | From 0.4.0 | 0.4.2 |
| `trestle-auth` | RubyGems | From 0.4.0 | 0.4.2 |

Products: Trestle-Auth Project Trestle-Auth.

## How do I fix CVE-2021-29435?

Upgrade trestle-auth to 0.4.2 or later.

## Is CVE-2021-29435 being exploited?

There is no known exploitation of CVE-2021-29435 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-29435 and fix it if it is affected.

What it is: CVE-2021-29435 is a high-severity vulnerability in TrestleAdmin trestle-auth, published on 13 Apr 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-29435 in the wild and no public exploit code.

Affected packages and fixed versions:
- trestle-auth (RubyGems): affected from 0.4.0; fixed in 0.4.2
- trestle-auth (RubyGems): affected from 0.4.0; fixed in 0.4.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-29435/ (Markdown: https://insights.sbomify.com/CVE-2021-29435/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-29435
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-29435
- OSV: https://osv.dev/vulnerability/CVE-2021-29435

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-29435/
Summaries are generated and may contain mistakes; the official description above is the record.
