{"answers":{"affected":"2 open source packages ship an affected version, including @nextcloud/dialogs. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-29438 in the wild and no public exploit code.","fix":"Upgrade @nextcloud/dialogs to 3.1.2 or later.","what":"CVE-2021-29438 is a medium-severity cross-site scripting vulnerability in nextcloud-dialogs, published on 13 Apr 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-29438 and fix it if it is affected.\n\nWhat it is: CVE-2021-29438 is a medium-severity cross-site scripting vulnerability in nextcloud-dialogs, published on 13 Apr 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2021-29438 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @nextcloud/dialogs (npm): affected all versions; fixed in 3.1.2\n- @nextcloud/dialogs (npm): affected all versions; fixed in 3.1.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-29438/ (Markdown: https://insights.sbomify.com/CVE-2021-29438/index.md)","id":"CVE-2021-29438","markdown":"https://insights.sbomify.com/CVE-2021-29438/index.md","name":"CVE-2021-29438","record":{"aliases":["GHSA-g3fq-3v3g-mh32"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Nextcloud dialogs library","requires_auth":"low_privilege","summary":"An attacker can execute arbitrary scripts via insufficiently escaped user input in Nextcloud dialog toasts, affecting applications using the library.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"nextcloud\\/dialogs","vendor":"nextcloud\\/dialogs_project"}],"cvss":{"score":4.6,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-80","name":"Improper Neutralization of Script-Related HTML Tags in a Web Page"},{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"The Nextcloud dialogs library (npm package @nextcloud/dialogs) before 3.1.2 insufficiently escaped text input passed to a toast. If your application displays toasts with user-supplied input, this could lead to a XSS vulnerability. The vulnerability has been patched in version 3.1.2 If you need to display HTML in the toast, explicitly pass the `options.isHTML` config flag.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) in @nextcloud/dialogs","id":"CVE-2021-29438","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2021"},"n_packages":2,"n_references":2,"next":{"headline":"Plugins can be installed with minimal admin privileges","id":"CVE-2021-29439"},"packages":[{"ecosystem":"npm","fixed":["3.1.2"],"introduced":["0"],"last_affected":[],"package":"@nextcloud/dialogs","purl":null,"source":"GHSA-g3fq-3v3g-mh32"},{"ecosystem":"npm","fixed":["3.1.2"],"introduced":["0"],"last_affected":[],"package":"@nextcloud/dialogs","purl":"pkg:npm/%40nextcloud/dialogs","source":"GHSA-g3fq-3v3g-mh32"}],"prev":{"headline":"Account compromise by man-in-the-middle attack","id":"CVE-2021-29437"},"products":["nextcloud-dialogs"],"published":"2021-04-13","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["nextcloud"]},"summary":"An attacker can execute arbitrary scripts via insufficiently escaped user input in Nextcloud dialog toasts, affecting applications using the library.","url":"https://insights.sbomify.com/CVE-2021-29438/"}