# CVE-2021-29438: Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) in @nextcloud/dialogs

> An attacker can execute arbitrary scripts via insufficiently escaped user input in Nextcloud dialog toasts, affecting applications using the library.

- **Severity:** Medium 4.6 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 13 Apr 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-g3fq-3v3g-mh32

## What is CVE-2021-29438?

CVE-2021-29438 is a medium-severity cross-site scripting vulnerability in nextcloud-dialogs, published on 13 Apr 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

The Nextcloud dialogs library (npm package @nextcloud/dialogs) before 3.1.2 insufficiently escaped text input passed to a toast. If your application displays toasts with user-supplied input, this could lead to a XSS vulnerability. The vulnerability has been patched in version 3.1.2 If you need to display HTML in the toast, explicitly pass the `options.isHTML` config flag.

Weakness: CWE-80 (Improper Neutralization of Script-Related HTML Tags in a Web Page), CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-29438?

2 open source packages ship an affected version, including @nextcloud/dialogs. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@nextcloud/dialogs` | npm | All versions | 3.1.2 |
| `@nextcloud/dialogs` | npm | All versions | 3.1.2 |

Products: Nextcloud\/Dialogs Project Nextcloud\/Dialogs.

## How do I fix CVE-2021-29438?

Upgrade @nextcloud/dialogs to 3.1.2 or later.

## Is CVE-2021-29438 being exploited?

There is no known exploitation of CVE-2021-29438 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-29438 and fix it if it is affected.

What it is: CVE-2021-29438 is a medium-severity cross-site scripting vulnerability in nextcloud-dialogs, published on 13 Apr 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-29438 in the wild and no public exploit code.

Affected packages and fixed versions:
- @nextcloud/dialogs (npm): affected all versions; fixed in 3.1.2
- @nextcloud/dialogs (npm): affected all versions; fixed in 3.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-29438/ (Markdown: https://insights.sbomify.com/CVE-2021-29438/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-29438
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-29438
- OSV: https://osv.dev/vulnerability/CVE-2021-29438

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-29438/
Summaries are generated and may contain mistakes; the official description above is the record.
