{"answers":{"affected":"2 open source packages ship an affected version, including getgrav/grav. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-29440 in the wild and no public exploit code.","fix":"Upgrade getgrav/grav to 1.7.11 or later.","what":"CVE-2021-29440 is a high-severity vulnerability in Getgrav Grav, published on 13 Apr 2021."},"fix_prompt":"Check this codebase for CVE-2021-29440 and fix it if it is affected.\n\nWhat it is: CVE-2021-29440 is a high-severity vulnerability in Getgrav Grav, published on 13 Apr 2021. \nExploitation: There is no known exploitation of CVE-2021-29440 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- getgrav/grav (Packagist): affected all versions; fixed in 1.7.11\n- getgrav/grav (Packagist): affected all versions; fixed in 1.7.11\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-29440/ (Markdown: https://insights.sbomify.com/CVE-2021-29440/index.md)","id":"CVE-2021-29440","markdown":"https://insights.sbomify.com/CVE-2021-29440/index.md","name":"CVE-2021-29440","record":{"aliases":["GHSA-g8r4-p96j-xfxc"],"analysis":null,"analysis_generated_by":null,"assigner":"GitHub_M","cpe":[{"product":"grav","vendor":"getgrav"}],"cvss":{"score":8.4,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"Grav is a file based Web-platform. Twig processing of static pages can be enabled in the front matter by any administrative user allowed to create or edit pages. As the Twig processor runs unsandboxed, this behavior can be used to gain arbitrary code execution and elevate privileges on the instance. The issue was addressed in version 1.7.11.","ecosystems":["Packagist"],"exploits":{"exploitdb":1,"first_seen":"2021-06-06","github_poc":1,"max_poc_stars":4,"metasploit":0,"nuclei":0,"refs":[{"date":"2021-06-06T00:51:21Z","kind":"github_poc","ref":"https://github.com/CsEnox/CVE-2021-29440","stars":4,"title":"Unsafe Twig processing of static pages leading to RCE in Grav CMS 1.7.10"},{"date":"2021-06-07","kind":"exploitdb","ref":"49961","stars":null,"title":"Grav CMS 1.7.10 - Server-Side Template Injection (SSTI) (Authenticated)"}],"tier":"poc_unverified"},"has_fix":true,"headline":"Twig allowing dangerous PHP functions by default","id":"CVE-2021-29440","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"getgrav:grav","products":["getgrav:grav"],"type":null,"year":"2021"},"n_packages":2,"n_references":4,"next":{"headline":"Authentication bypass","id":"CVE-2021-29441"},"packages":[{"ecosystem":"Packagist","fixed":["1.7.11"],"introduced":["0"],"last_affected":[],"package":"getgrav/grav","purl":null,"source":"GHSA-g8r4-p96j-xfxc"},{"ecosystem":"Packagist","fixed":["1.7.11"],"introduced":["0"],"last_affected":[],"package":"getgrav/grav","purl":"pkg:composer/getgrav/grav","source":"GHSA-g8r4-p96j-xfxc"}],"prev":{"headline":"Plugins can be installed with minimal admin privileges","id":"CVE-2021-29439"},"products":["grav"],"published":"2021-04-13","related":[{"cvss_score":10,"headline":"Grav Server Side Template Injection vulnerability","id":"CVE-2023-34251","kev_date_added":null,"published":"2023-06-14"},{"cvss_score":9.8,"headline":"Cross-site scripting in n/a","id":"CVE-2025-46199","kev_date_added":null,"published":"2025-07-25"},{"cvss_score":9.3,"headline":"GravCMS 1.10.7 - Arbitrary YAML Write/Update (Unauthenticated) (2)","id":"CVE-2021-47812","kev_date_added":null,"published":"2026-01-15"},{"cvss_score":9.1,"headline":"Grav may be vulnerable to SSRF attack via Twig Templates","id":"CVE-2025-66844","kev_date_added":null,"published":"2025-12-15"},{"cvss_score":9.1,"headline":"Code Injection in getgrav/grav","id":"CVE-2022-2073","kev_date_added":null,"published":"2022-06-29"},{"cvss_score":8.9,"headline":"Grav: Stored XSS via Tag Injection","id":"CVE-2026-42611","kev_date_added":null,"published":"2026-05-11"},{"cvss_score":8.8,"headline":"Grav: Unauthenticated Path Traversal \u0026 Arbitrary File Write in FormFlash component.","id":"CVE-2026-42608","kev_date_added":null,"published":"2026-05-11"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["getgrav"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2021-29440/"}