# CVE-2021-29440: Twig allowing dangerous PHP functions by default


- **Severity:** High 8.4 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 13 Apr 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-g8r4-p96j-xfxc

## What is CVE-2021-29440?

CVE-2021-29440 is a high-severity vulnerability in Getgrav Grav, published on 13 Apr 2021. 

### Official description

Grav is a file based Web-platform. Twig processing of static pages can be enabled in the front matter by any administrative user allowed to create or edit pages. As the Twig processor runs unsandboxed, this behavior can be used to gain arbitrary code execution and elevate privileges on the instance. The issue was addressed in version 1.7.11.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2021-29440?

2 open source packages ship an affected version, including getgrav/grav. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `getgrav/grav` | Packagist | All versions | 1.7.11 |
| `getgrav/grav` | Packagist | All versions | 1.7.11 |

Products: Getgrav Grav.

## How do I fix CVE-2021-29440?

Upgrade getgrav/grav to 1.7.11 or later.

## Is CVE-2021-29440 being exploited?

There is no known exploitation of CVE-2021-29440 in the wild and no public exploit code.

Public exploit code:

- Unsafe Twig processing of static pages leading to RCE in Grav CMS 1.7.10 (github_poc): https://github.com/CsEnox/CVE-2021-29440
- Grav CMS 1.7.10 - Server-Side Template Injection (SSTI) (Authenticated) (exploitdb)

## Other vulnerabilities in Getgrav Grav

- [CVE-2023-34251](https://insights.sbomify.com/CVE-2023-34251/): Grav Server Side Template Injection vulnerability (critical 10.0)
- [CVE-2025-46199](https://insights.sbomify.com/CVE-2025-46199/): Cross-site scripting in n/a (critical 9.8)
- [CVE-2021-47812](https://insights.sbomify.com/CVE-2021-47812/): GravCMS 1.10.7 - Arbitrary YAML Write/Update (Unauthenticated) (2) (critical 9.3)
- [CVE-2025-66844](https://insights.sbomify.com/CVE-2025-66844/): Grav may be vulnerable to SSRF attack via Twig Templates (critical 9.1)
- [CVE-2022-2073](https://insights.sbomify.com/CVE-2022-2073/): Code Injection in getgrav/grav (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-29440 and fix it if it is affected.

What it is: CVE-2021-29440 is a high-severity vulnerability in Getgrav Grav, published on 13 Apr 2021. 
Exploitation: There is no known exploitation of CVE-2021-29440 in the wild and no public exploit code.

Affected packages and fixed versions:
- getgrav/grav (Packagist): affected all versions; fixed in 1.7.11
- getgrav/grav (Packagist): affected all versions; fixed in 1.7.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-29440/ (Markdown: https://insights.sbomify.com/CVE-2021-29440/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-29440
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-29440
- OSV: https://osv.dev/vulnerability/CVE-2021-29440

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-29440/
Summaries are generated and may contain mistakes; the official description above is the record.
