# CVE-2021-29443: Padding Oracle Attack due to Observable Timing Discrepancy in jose

> An attacker can decrypt data without the key by exploiting timing discrepancies in the jose library's AES-CBC-HMAC decryption process.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Apr 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-58f5-hfqc-jgch

## What is CVE-2021-29443?

CVE-2021-29443 is a medium-severity vulnerability in panva jose, published on 16 Apr 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

jose is an npm library providing a number of cryptographic operations. In vulnerable versions AES_CBC_HMAC_SHA2 Algorithm (A128CBC-HS256, A192CBC-HS384, A256CBC-HS512) decryption would always execute both HMAC tag verification and CBC decryption, if either failed `JWEDecryptionFailed` would be thrown. A possibly observable difference in timing when padding error would occur while decrypting the ciphertext makes a padding oracle and an adversary might be able to make use of that oracle to decrypt data without knowing the decryption key by issuing on average 128*b calls to the padding oracle (where b is the number of bytes in the ciphertext block). All major release versions have had a patch released which ensures the HMAC tag is verified before performing CBC decryption. The fixed versions are `^1.28.1 || ^2.0.5 || >=3.11.4`. Users should upgrade their v1.x dependency to ^1.28.1, their v2.x dependency to ^2.0.5, and their v3.x dependency to ^3.11.4. Thanks to Jason from Microsoft Vulnerability Research (MSVR) for bringing this up and Eva Sarafianou (@esarafianou) for helping to score this advisory.

Weakness: CWE-203 (Observable Discrepancy)

## Which versions are affected by CVE-2021-29443?

6 open source packages ship an affected version, including jose. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jose` | npm | From 1.0.0 | 1.28.1 |
| `jose` | npm | From 1.0.0 | 1.28.1 |
| `jose` | npm | From 2.0.0 | 2.0.5 |
| `jose` | npm | From 2.0.0 | 2.0.5 |
| `jose` | npm | From 3.0.0 | 3.11.4 |
| `jose` | npm | From 3.0.0 | 3.11.4 |

Products: Panva Jose.

## How do I fix CVE-2021-29443?

Upgrade jose to a fixed version for your release line: 1.28.1, 2.0.5 or 3.11.4.

## Is CVE-2021-29443 being exploited?

There is no known exploitation of CVE-2021-29443 in the wild and no public exploit code.

## Other vulnerabilities in panva jose

- [CVE-2022-36083](https://insights.sbomify.com/CVE-2022-36083/): JOSE vulnerable to resource exhaustion via specifically crafted JWE (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-29443 and fix it if it is affected.

What it is: CVE-2021-29443 is a medium-severity vulnerability in panva jose, published on 16 Apr 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-29443 in the wild and no public exploit code.

Affected packages and fixed versions:
- jose (npm): affected from 1.0.0; fixed in 1.28.1
- jose (npm): affected from 1.0.0; fixed in 1.28.1
- jose (npm): affected from 2.0.0; fixed in 2.0.5
- jose (npm): affected from 2.0.0; fixed in 2.0.5
- jose (npm): affected from 3.0.0; fixed in 3.11.4
- jose (npm): affected from 3.0.0; fixed in 3.11.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-29443/ (Markdown: https://insights.sbomify.com/CVE-2021-29443/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-29443
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-29443
- OSV: https://osv.dev/vulnerability/CVE-2021-29443

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-29443/
Summaries are generated and may contain mistakes; the official description above is the record.
