{"answers":{"affected":"2 open source packages ship an affected version, including wordpress and wordpress-multisite. It affects 2 products.","exploited":"There is no known exploitation of CVE-2021-29447 in the wild and no public exploit code.","fix":"Upgrade wordpress to 5.7.1 or later.","what":"CVE-2021-29447 is a high-severity vulnerability in Debian Debian Linux, published on 15 Apr 2021. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-29447 and fix it if it is affected.\n\nWhat it is: CVE-2021-29447 is a high-severity vulnerability in Debian Debian Linux, published on 15 Apr 2021. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-29447 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- wordpress (Bitnami): affected from 5.6.0; fixed in 5.7.1\n- wordpress-multisite (Bitnami): affected from 5.6.0; fixed in 5.7.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-29447/ (Markdown: https://insights.sbomify.com/CVE-2021-29447/index.md)","id":"CVE-2021-29447","markdown":"https://insights.sbomify.com/CVE-2021-29447/index.md","name":"CVE-2021-29447","record":{"aliases":["BIT-wordpress-2021-29447","BIT-wordpress-multisite-2021-29447","DEBIAN-CVE-2021-29447","GHSA-rv47-pc52-qrhh","UBUNTU-CVE-2021-29447"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":true,"product_category":"WordPress CMS","requires_auth":"low_privilege","summary":"Authenticated users can exploit an XML parsing flaw in the Media Library to read internal files when running PHP 8.","user_interaction":"not_required","vuln_class":"xxe"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"wordpress","vendor":"wordpress"}],"cvss":{"score":7.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-611","name":"Improper Restriction of XML External Entity Reference"}],"description":"Wordpress is an open source CMS. A user with the ability to upload files (like an Author) can exploit an XML parsing issue in the Media Library leading to XXE attacks. This requires WordPress installation to be using PHP 8. Access to internal files is possible in a successful XXE attack. This has been patched in WordPress version 5.7.1, along with the older affected versions via a minor release. We strongly recommend you keep auto-updates enabled.","ecosystems":["Bitnami"],"exploits":{"exploitdb":1,"first_seen":"2021-04-16","github_poc":24,"max_poc_stars":44,"metasploit":0,"nuclei":0,"refs":[{"date":"2021-04-16T20:41:26Z","kind":"github_poc","ref":"https://github.com/motikan2010/CVE-2021-29447","stars":44,"title":"WordPress - Authenticated XXE (CVE-2021-29447)"},{"date":"2022-11-14T17:05:27Z","kind":"github_poc","ref":"https://github.com/mega8bit/exploit_cve-2021-29447","stars":7,"title":null},{"date":"2023-01-24T16:43:13Z","kind":"github_poc","ref":"https://github.com/0xRar/CVE-2021-29447-PoC","stars":6,"title":"A proof of concept exploit for a wordpress 5.6 media library vulnerability"},{"date":"2021-05-23T14:08:34Z","kind":"github_poc","ref":"https://github.com/Vulnmachines/wordpress_cve-2021-29447","stars":4,"title":"WordPress XXE vulnerability"},{"date":"2022-11-11T22:41:45Z","kind":"github_poc","ref":"https://github.com/M3l0nPan/wordpress-cve-2021-29447","stars":4,"title":"Exploit WordPress Media Library XML External Entity Injection (XXE) to exfiltrate files."},{"date":"2021-06-01T10:10:25Z","kind":"github_poc","ref":"https://github.com/dnr6419/CVE-2021-29447","stars":3,"title":"Wordpress XXE injection 구축 자동화 및 PoC "},{"date":"2022-11-06T04:26:20Z","kind":"github_poc","ref":"https://github.com/elf1337/blind-xxe-controller-CVE-2021-29447","stars":3,"title":"Arbitrary file read controller based on CVE-2021-29447"},{"date":"2022-11-15T03:15:59Z","kind":"github_poc","ref":"https://github.com/thomas-osgood/CVE-2021-29447","stars":3,"title":"A Golang program to automate the execution of CVE-2021-29447"}],"tier":"poc_unverified"},"has_fix":true,"headline":"WordPress Authenticated XXE attack when installation is running PHP 8","id":"CVE-2021-29447","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"debian:debian_linux","products":["debian:debian_linux","wordpress:wordpress"],"type":"xxe","year":"2021"},"n_packages":2,"n_references":7,"next":{"headline":"Stored DOM XSS in Pi-hole Admin Web Interface","id":"CVE-2021-29448"},"packages":[{"ecosystem":"Bitnami","fixed":["5.7.1"],"introduced":["5.6.0"],"last_affected":[],"package":"wordpress","purl":"pkg:bitnami/wordpress","source":"BIT-wordpress-2021-29447"},{"ecosystem":"Bitnami","fixed":["5.7.1"],"introduced":["5.6.0"],"last_affected":[],"package":"wordpress-multisite","purl":"pkg:bitnami/wordpress-multisite","source":"BIT-wordpress-multisite-2021-29447"}],"prev":{"headline":"Padding Oracle Attack due to Observable Timing Discrepancy in jose-node-cjs-runtime","id":"CVE-2021-29446"},"products":["wordpress-develop"],"published":"2021-04-15","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["WordPress"]},"summary":"Authenticated users can exploit an XML parsing flaw in the Media Library to read internal files when running PHP 8.","url":"https://insights.sbomify.com/CVE-2021-29447/"}