CVE-2021-29450 WordPress Authenticated disclosure of password-protected posts and pages

Medium 6.5 Published Updated

Authenticated users with contributor privileges can expose password-protected posts and pages via a specific editor block.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2021-29450?

CVE-2021-29450 is a medium-severity vulnerability in Debian Debian Linux, published on 15 Apr 2021. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Wordpress is an open source CMS. One of the blocks in the WordPress editor can be exploited in a way that exposes password-protected posts and pages. This requires at least contributor privileges. This has been patched in WordPress 5.7.1, along with the older affected versions via minor releases. It's strongly recommended that you keep auto-updates enabled to receive the fix.

Weakness: CWE-200

Which versions are affected by CVE-2021-29450?

2 open source packages ship an affected version, including wordpress and wordpress-multisite. It affects 2 products.

PackageAffectedFixed in
wordpress BitnamiFrom 4.7.05.7.1
wordpress-multisite BitnamiFrom 4.7.05.7.1

Products include Debian Debian Linux, Wordpress Wordpress.

How do I fix CVE-2021-29450?

Upgrade wordpress to 5.7.1 or later.

Is CVE-2021-29450 being exploited?

There is no known exploitation of CVE-2021-29450 in the wild and no public exploit code.

All Debian Debian Linux vulnerabilities

Sources

Also known as BIT-wordpress-2021-29450, BIT-wordpress-multisite-2021-29450, DEBIAN-CVE-2021-29450, GHSA-pmmh-2f36-wvhq, UBUNTU-CVE-2021-29450.

Is CVE-2021-29450 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free