{"answers":{"affected":"2 open source packages ship an affected version, including wordpress and wordpress-multisite. It affects 2 products.","exploited":"There is no known exploitation of CVE-2021-29450 in the wild and no public exploit code.","fix":"Upgrade wordpress to 5.7.1 or later.","what":"CVE-2021-29450 is a medium-severity vulnerability in Debian Debian Linux, published on 15 Apr 2021. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-29450 and fix it if it is affected.\n\nWhat it is: CVE-2021-29450 is a medium-severity vulnerability in Debian Debian Linux, published on 15 Apr 2021. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-29450 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- wordpress (Bitnami): affected from 4.7.0; fixed in 5.7.1\n- wordpress-multisite (Bitnami): affected from 4.7.0; fixed in 5.7.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-29450/ (Markdown: https://insights.sbomify.com/CVE-2021-29450/index.md)","id":"CVE-2021-29450","markdown":"https://insights.sbomify.com/CVE-2021-29450/index.md","name":"CVE-2021-29450","record":{"aliases":["BIT-wordpress-2021-29450","BIT-wordpress-multisite-2021-29450","DEBIAN-CVE-2021-29450","GHSA-pmmh-2f36-wvhq","UBUNTU-CVE-2021-29450"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress CMS","requires_auth":"low_privilege","summary":"Authenticated users with contributor privileges can expose password-protected posts and pages via a specific editor block.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"wordpress","vendor":"wordpress"}],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"Wordpress is an open source CMS. One of the blocks in the WordPress editor can be exploited in a way that exposes password-protected posts and pages. This requires at least contributor privileges. This has been patched in WordPress 5.7.1, along with the older affected versions via minor releases. It's strongly recommended that you keep auto-updates enabled to receive the fix.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"WordPress Authenticated disclosure of password-protected posts and pages","id":"CVE-2021-29450","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"debian:debian_linux","products":["debian:debian_linux","wordpress:wordpress"],"type":"information_disclosure","year":"2021"},"n_packages":2,"n_references":4,"next":{"headline":"Missing validation of JWT signature in `ManyDesigns/Portofino`","id":"CVE-2021-29451"},"packages":[{"ecosystem":"Bitnami","fixed":["5.7.1"],"introduced":["4.7.0"],"last_affected":[],"package":"wordpress","purl":"pkg:bitnami/wordpress","source":"BIT-wordpress-2021-29450"},{"ecosystem":"Bitnami","fixed":["5.7.1"],"introduced":["4.7.0"],"last_affected":[],"package":"wordpress-multisite","purl":"pkg:bitnami/wordpress-multisite","source":"BIT-wordpress-multisite-2021-29450"}],"prev":{"headline":"Multiple Privilege Escalation Vulnerabilities Pihole","id":"CVE-2021-29449"},"products":["wordpress-develop"],"published":"2021-04-15","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["WordPress"]},"summary":"Authenticated users with contributor privileges can expose password-protected posts and pages via a specific editor block.","url":"https://insights.sbomify.com/CVE-2021-29450/"}