# CVE-2021-29450: WordPress Authenticated disclosure of password-protected posts and pages

> Authenticated users with contributor privileges can expose password-protected posts and pages via a specific editor block.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Apr 2021
- **Updated:** 3 Aug 2024
- **Also known as:** BIT-wordpress-2021-29450, BIT-wordpress-multisite-2021-29450, DEBIAN-CVE-2021-29450, GHSA-pmmh-2f36-wvhq, UBUNTU-CVE-2021-29450

## What is CVE-2021-29450?

CVE-2021-29450 is a medium-severity vulnerability in Debian Debian Linux, published on 15 Apr 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Wordpress is an open source CMS. One of the blocks in the WordPress editor can be exploited in a way that exposes password-protected posts and pages. This requires at least contributor privileges. This has been patched in WordPress 5.7.1, along with the older affected versions via minor releases. It's strongly recommended that you keep auto-updates enabled to receive the fix.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2021-29450?

2 open source packages ship an affected version, including wordpress and wordpress-multisite. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wordpress` | Bitnami | From 4.7.0 | 5.7.1 |
| `wordpress-multisite` | Bitnami | From 4.7.0 | 5.7.1 |

Products: Debian Debian Linux, Wordpress Wordpress.

## How do I fix CVE-2021-29450?

Upgrade wordpress to 5.7.1 or later.

## Is CVE-2021-29450 being exploited?

There is no known exploitation of CVE-2021-29450 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-29450 and fix it if it is affected.

What it is: CVE-2021-29450 is a medium-severity vulnerability in Debian Debian Linux, published on 15 Apr 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-29450 in the wild and no public exploit code.

Affected packages and fixed versions:
- wordpress (Bitnami): affected from 4.7.0; fixed in 5.7.1
- wordpress-multisite (Bitnami): affected from 4.7.0; fixed in 5.7.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-29450/ (Markdown: https://insights.sbomify.com/CVE-2021-29450/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-29450
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-29450
- OSV: https://osv.dev/vulnerability/CVE-2021-29450

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-29450/
Summaries are generated and may contain mistakes; the official description above is the record.
