# CVE-2021-29452: Any logged in user could edit any other logged in user.

> Any authenticated user can modify other users' data due to incorrect privilege checks in the a12n-server authentication library.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Apr 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-8hw9-22v6-9jr9

## What is CVE-2021-29452?

CVE-2021-29452 is a high-severity missing authorization vulnerability in curveball a12n-server, published on 16 Apr 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

a12n-server is an npm package which aims to provide a simple authentication system. A new HAL-Form was added to allow editing users in version 0.18.0. This feature should only have been accessible to admins. Unfortunately, privileges were incorrectly checked allowing any logged in user to make this change. Patched in v0.18.2.

Weakness: CWE-863 (Incorrect Authorization), CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2021-29452?

2 open source packages ship an affected version, including @curveball/a12n-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@curveball/a12n-server` | npm | From 0.18.0 | 0.18.2 |
| `@curveball/a12n-server` | npm | From 0.18.0 | 0.18.2 |

Products: Curveballjs A12n-Server.

## How do I fix CVE-2021-29452?

Upgrade @curveball/a12n-server to 0.18.2 or later.

## Is CVE-2021-29452 being exploited?

There is no known exploitation of CVE-2021-29452 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-29452 and fix it if it is affected.

What it is: CVE-2021-29452 is a high-severity missing authorization vulnerability in curveball a12n-server, published on 16 Apr 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-29452 in the wild and no public exploit code.

Affected packages and fixed versions:
- @curveball/a12n-server (npm): affected from 0.18.0; fixed in 0.18.2
- @curveball/a12n-server (npm): affected from 0.18.0; fixed in 0.18.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-29452/ (Markdown: https://insights.sbomify.com/CVE-2021-29452/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-29452
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-29452
- OSV: https://osv.dev/vulnerability/CVE-2021-29452

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-29452/
Summaries are generated and may contain mistakes; the official description above is the record.
