{"answers":{"affected":"4 open source packages ship an affected version, including smarty/smarty. It affects 3 products.","exploited":"There is no known exploitation of CVE-2021-29454 in the wild and no public exploit code.","fix":"Upgrade smarty/smarty to a fixed version for your release line: 3.1.42 or 4.0.2.","what":"CVE-2021-29454 is a high-severity code injection vulnerability in Debian Debian Linux, published on 10 Jan 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-29454 and fix it if it is affected.\n\nWhat it is: CVE-2021-29454 is a high-severity code injection vulnerability in Debian Debian Linux, published on 10 Jan 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2021-29454 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- smarty/smarty (Packagist): affected all versions; fixed in 3.1.42\n- smarty/smarty (Packagist): affected all versions; fixed in 3.1.42\n- smarty/smarty (Packagist): affected from 4.0.0; fixed in 4.0.2\n- smarty/smarty (Packagist): affected from 4.0.0; fixed in 4.0.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-29454/ (Markdown: https://insights.sbomify.com/CVE-2021-29454/index.md)","id":"CVE-2021-29454","markdown":"https://insights.sbomify.com/CVE-2021-29454/index.md","name":"CVE-2021-29454","record":{"aliases":["DEBIAN-CVE-2021-29454","GHSA-29gp-2c3m-3j6m","UBUNTU-CVE-2021-29454"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP template engine","requires_auth":"none","summary":"Attackers can execute arbitrary PHP code via malicious math strings in the Smarty template engine, requiring an upgrade to patched versions.","user_interaction":"required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"fedora","vendor":"fedoraproject"},{"product":"smarty","vendor":"smarty"}],"cvss":{"score":8.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-74","name":"Improper Neutralization of Special Elements in Output Used by a Downstream Component"}],"description":"Smarty is a template engine for PHP, facilitating the separation of presentation (HTML/CSS) from application logic. Prior to versions 3.1.42 and 4.0.2, template authors could run arbitrary PHP code by crafting a malicious math string. If a math string was passed through as user provided data to the math function, external users could run arbitrary PHP code by crafting a malicious math string. Users should upgrade to version 3.1.42 or 4.0.2 to receive a patch.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Sandbox Escape by math function in smarty","id":"CVE-2021-29454","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"debian:debian_linux","products":["debian:debian_linux","fedoraproject:fedora"],"type":"code_injection","year":"2021"},"n_packages":4,"n_references":11,"next":{"headline":"Missing validation of JWT signature in `grassrootza/grassroot-platform`","id":"CVE-2021-29455"},"packages":[{"ecosystem":"Packagist","fixed":["3.1.42"],"introduced":["0"],"last_affected":[],"package":"smarty/smarty","purl":null,"source":"GHSA-29gp-2c3m-3j6m"},{"ecosystem":"Packagist","fixed":["3.1.42"],"introduced":["0"],"last_affected":[],"package":"smarty/smarty","purl":"pkg:composer/smarty/smarty","source":"GHSA-29gp-2c3m-3j6m"},{"ecosystem":"Packagist","fixed":["4.0.2"],"introduced":["4.0.0"],"last_affected":[],"package":"smarty/smarty","purl":null,"source":"GHSA-29gp-2c3m-3j6m"},{"ecosystem":"Packagist","fixed":["4.0.2"],"introduced":["4.0.0"],"last_affected":[],"package":"smarty/smarty","purl":"pkg:composer/smarty/smarty","source":"GHSA-29gp-2c3m-3j6m"}],"prev":{"headline":"Denial of service through memory exhaustion","id":"CVE-2021-29453"},"products":["smarty"],"published":"2022-01-10","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["smarty-php"]},"summary":"Attackers can execute arbitrary PHP code via malicious math strings in the Smarty template engine, requiring an upgrade to patched versions.","url":"https://insights.sbomify.com/CVE-2021-29454/"}