# CVE-2021-29454: Sandbox Escape by math function in smarty

> Attackers can execute arbitrary PHP code via malicious math strings in the Smarty template engine, requiring an upgrade to patched versions.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 Jan 2022
- **Updated:** 23 Apr 2025
- **Also known as:** DEBIAN-CVE-2021-29454, GHSA-29gp-2c3m-3j6m, UBUNTU-CVE-2021-29454

## What is CVE-2021-29454?

CVE-2021-29454 is a high-severity code injection vulnerability in Debian Debian Linux, published on 10 Jan 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Smarty is a template engine for PHP, facilitating the separation of presentation (HTML/CSS) from application logic. Prior to versions 3.1.42 and 4.0.2, template authors could run arbitrary PHP code by crafting a malicious math string. If a math string was passed through as user provided data to the math function, external users could run arbitrary PHP code by crafting a malicious math string. Users should upgrade to version 3.1.42 or 4.0.2 to receive a patch.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2021-29454?

4 open source packages ship an affected version, including smarty/smarty. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `smarty/smarty` | Packagist | All versions | 3.1.42 |
| `smarty/smarty` | Packagist | All versions | 3.1.42 |
| `smarty/smarty` | Packagist | From 4.0.0 | 4.0.2 |
| `smarty/smarty` | Packagist | From 4.0.0 | 4.0.2 |

Products: Debian Debian Linux, Fedoraproject Fedora, Smarty Smarty.

## How do I fix CVE-2021-29454?

Upgrade smarty/smarty to a fixed version for your release line: 3.1.42 or 4.0.2.

## Is CVE-2021-29454 being exploited?

There is no known exploitation of CVE-2021-29454 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-29454 and fix it if it is affected.

What it is: CVE-2021-29454 is a high-severity code injection vulnerability in Debian Debian Linux, published on 10 Jan 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-29454 in the wild and no public exploit code.

Affected packages and fixed versions:
- smarty/smarty (Packagist): affected all versions; fixed in 3.1.42
- smarty/smarty (Packagist): affected all versions; fixed in 3.1.42
- smarty/smarty (Packagist): affected from 4.0.0; fixed in 4.0.2
- smarty/smarty (Packagist): affected from 4.0.0; fixed in 4.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-29454/ (Markdown: https://insights.sbomify.com/CVE-2021-29454/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-29454
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-29454
- OSV: https://osv.dev/vulnerability/CVE-2021-29454

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-29454/
Summaries are generated and may contain mistakes; the official description above is the record.
