CVE-2021-29458 Out-of-bounds read in Exiv2::Internal::CrwMap::encode

Medium 5.5 Published Updated

An attacker can cause a denial of service by tricking a user into writing metadata to a crafted image file using the Exiv2 library.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Local or same network only
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2021-29458?

CVE-2021-29458 is a medium-severity denial of service vulnerability in Debian Debian Linux, published on 19 Apr 2021. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

Official description

Exiv2 is a command-line utility and C++ library for reading, writing, deleting, and modifying the metadata of image files. An out-of-bounds read was found in Exiv2 versions v0.27.3 and earlier. The out-of-bounds read is triggered when Exiv2 is used to write metadata into a crafted image file. An attacker could potentially exploit the vulnerability to cause a denial of service by crashing Exiv2, if they can trick the victim into running Exiv2 on a crafted image file. Note that this bug is only triggered when writing the metadata, which is a less frequently used Exiv2 operation than reading the metadata. For example, to trigger the bug in the Exiv2 command-line application, you need to add an extra command-line argument such as insert. The bug is fixed in version v0.27.4.

Weakness: CWE-125

Which versions are affected by CVE-2021-29458?

It affects 3 products.

Linux distribution packages (1)
exiv2 openSUSE:TumbleweedAll versions0.27.5-11.1

Products include Debian Debian Linux, Exiv2 Exiv2, Fedoraproject Fedora.

How do I fix CVE-2021-29458?

Upgrade to a fixed version.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2021-29458 being exploited?

There is no known exploitation of CVE-2021-29458 in the wild and no public exploit code.

All Debian Debian Linux vulnerabilities

Sources

Also known as AZL-7207, CLEANSTART-2024-WV01161, DEBIAN-CVE-2021-29458, GHSA-57jj-75fm-9rq5, UBUNTU-CVE-2021-29458, openSUSE-SU-2024:12591-1.

Is CVE-2021-29458 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free