# CVE-2021-29458: Out-of-bounds read in Exiv2::Internal::CrwMap::encode

> An attacker can cause a denial of service by tricking a user into writing metadata to a crafted image file using the Exiv2 library.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 Apr 2021
- **Updated:** 3 Aug 2024
- **Also known as:** AZL-7207, CLEANSTART-2024-WV01161, DEBIAN-CVE-2021-29458, GHSA-57jj-75fm-9rq5, UBUNTU-CVE-2021-29458, openSUSE-SU-2024:12591-1

## What is CVE-2021-29458?

CVE-2021-29458 is a medium-severity denial of service vulnerability in Debian Debian Linux, published on 19 Apr 2021. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Exiv2 is a command-line utility and C++ library for reading, writing, deleting, and modifying the metadata of image files. An out-of-bounds read was found in Exiv2 versions v0.27.3 and earlier. The out-of-bounds read is triggered when Exiv2 is used to write metadata into a crafted image file. An attacker could potentially exploit the vulnerability to cause a denial of service by crashing Exiv2, if they can trick the victim into running Exiv2 on a crafted image file. Note that this bug is only triggered when writing the metadata, which is a less frequently used Exiv2 operation than reading the metadata. For example, to trigger the bug in the Exiv2 command-line application, you need to add an extra command-line argument such as insert. The bug is fixed in version v0.27.4.

Weakness: CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2021-29458?

It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `exiv2` | openSUSE:Tumbleweed | All versions | 0.27.5-11.1 |

Products: Debian Debian Linux, Exiv2 Exiv2, Fedoraproject Fedora.

## How do I fix CVE-2021-29458?

Upgrade to a fixed version.

## Is CVE-2021-29458 being exploited?

There is no known exploitation of CVE-2021-29458 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-29458 and fix it if it is affected.

What it is: CVE-2021-29458 is a medium-severity denial of service vulnerability in Debian Debian Linux, published on 19 Apr 2021. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-29458 in the wild and no public exploit code.

Affected product: Debian Debian Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-29458/ (Markdown: https://insights.sbomify.com/CVE-2021-29458/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-29458
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-29458
- OSV: https://osv.dev/vulnerability/CVE-2021-29458

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-29458/
Summaries are generated and may contain mistakes; the official description above is the record.
