CVE-2021-29459 XSS Cross Site Scripting
Attackers can inject persistent scripts via text fields, potentially executing code or taking over accounts in XWiki.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2021-29459?
CVE-2021-29459 is a critical cross-site scripting vulnerability in Xwiki Xwiki, published on 20 Apr 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. It is possible to persistently inject scripts in XWiki versions prior to 12.6.3 and 12.8. Unregistred users can fill simple text fields. Registered users can fill in their personal information and (if they have edit rights) fill the values of static lists using App Within Minutes. There is no easy workaround except upgrading XWiki. The vulnerability has been patched on XWiki 12.8 and 12.6.3.
Weakness: CWE-79
Which versions are affected by CVE-2021-29459?
8 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-oldcore and org.xwiki.platform:xwiki-platform-web. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.xwiki.platform:xwiki-platform-oldcore Maven | All versions | 12.6.3 |
org.xwiki.platform:xwiki-platform-oldcore Maven | All versions | 12.6.3 |
org.xwiki.platform:xwiki-platform-oldcore Maven | From 12.6.4 | 12.8 |
org.xwiki.platform:xwiki-platform-oldcore Maven | From 12.6.4 | 12.8 |
org.xwiki.platform:xwiki-platform-web Maven | All versions | 12.6.3 |
org.xwiki.platform:xwiki-platform-web Maven | All versions | 12.6.3 |
2 more packages
org.xwiki.platform:xwiki-platform-web Maven | From 12.6.4 | 12.8 |
org.xwiki.platform:xwiki-platform-web Maven | From 12.6.4 | 12.8 |
Products include Xwiki Xwiki.
How do I fix CVE-2021-29459?
Upgrade org.xwiki.platform:xwiki-platform-oldcore to a fixed version for your release line: 12.6.3 or 12.8.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2021-29459 being exploited?
There is no known exploitation of CVE-2021-29459 in the wild and no public exploit code.
Other vulnerabilities in Xwiki Xwiki
- CVE-2025-24893 XWiki Platform Eval Injection
- CVE-2025-53836 XWiki Rendering is vulnerable to RCE attacks when processing nested macros
- CVE-2024-55662 XWiki allows remote code execution through the extension sheet
- CVE-2024-55877 XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList
- CVE-2024-37901 XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet
Sources
Also known as GHSA-5c66-v29h-xjh8.