# CVE-2021-29459: XSS Cross Site Scripting

> Attackers can inject persistent scripts via text fields, potentially executing code or taking over accounts in XWiki.

- **Severity:** Critical 9.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 20 Apr 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-5c66-v29h-xjh8

## What is CVE-2021-29459?

CVE-2021-29459 is a critical cross-site scripting vulnerability in Xwiki Xwiki, published on 20 Apr 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. It is possible to persistently inject scripts in XWiki versions prior to 12.6.3 and 12.8. Unregistred users can fill simple text fields. Registered users can fill in their personal information and (if they have edit rights) fill the values of static lists using App Within Minutes. There is no easy workaround except upgrading XWiki. The vulnerability has been patched on XWiki 12.8 and 12.6.3.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-29459?

8 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-oldcore and org.xwiki.platform:xwiki-platform-web. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | All versions | 12.6.3 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | All versions | 12.6.3 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 12.6.4 | 12.8 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 12.6.4 | 12.8 |
| `org.xwiki.platform:xwiki-platform-web` | Maven | All versions | 12.6.3 |
| `org.xwiki.platform:xwiki-platform-web` | Maven | All versions | 12.6.3 |
| `org.xwiki.platform:xwiki-platform-web` | Maven | From 12.6.4 | 12.8 |
| `org.xwiki.platform:xwiki-platform-web` | Maven | From 12.6.4 | 12.8 |

Products: Xwiki Xwiki.

## How do I fix CVE-2021-29459?

Upgrade org.xwiki.platform:xwiki-platform-oldcore to a fixed version for your release line: 12.6.3 or 12.8.

## Is CVE-2021-29459 being exploited?

There is no known exploitation of CVE-2021-29459 in the wild and no public exploit code.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-29459 and fix it if it is affected.

What it is: CVE-2021-29459 is a critical cross-site scripting vulnerability in Xwiki Xwiki, published on 20 Apr 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-29459 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected all versions; fixed in 12.6.3
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected all versions; fixed in 12.6.3
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 12.6.4; fixed in 12.8
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 12.6.4; fixed in 12.8
- org.xwiki.platform:xwiki-platform-web (Maven): affected all versions; fixed in 12.6.3
- org.xwiki.platform:xwiki-platform-web (Maven): affected all versions; fixed in 12.6.3
- org.xwiki.platform:xwiki-platform-web (Maven): affected from 12.6.4; fixed in 12.8
- org.xwiki.platform:xwiki-platform-web (Maven): affected from 12.6.4; fixed in 12.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-29459/ (Markdown: https://insights.sbomify.com/CVE-2021-29459/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-29459
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-29459
- OSV: https://osv.dev/vulnerability/CVE-2021-29459

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-29459/
Summaries are generated and may contain mistakes; the official description above is the record.
