# CVE-2021-29460: Cross-site scripting (XSS) from unsanitized uploaded SVG files

> Attackers can upload malicious SVG files to execute scripts in admin sessions, enabling privilege escalation and account takeover in Kirby CMS.

- **Severity:** High 7.6 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 27 Apr 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-qgp4-5qx6-548g

## What is CVE-2021-29460?

CVE-2021-29460 is a high-severity cross-site scripting vulnerability in getkirby kirby, published on 27 Apr 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Kirby is an open source CMS. An editor with write access to the Kirby Panel can upload an SVG file that contains harmful content like `<script>` tags. The direct link to that file can be sent to other users or visitors of the site. If the victim opens that link in a browser where they are logged in to Kirby, the script will run and can for example trigger requests to Kirby's API with the permissions of the victim. This vulnerability is critical if you might have potential attackers in your group of authenticated Panel users, as they can escalate their privileges if they get access to the Panel session of an admin user. Depending on your site, other JavaScript-powered attacks are possible. Visitors without Panel access can only use this attack vector if your site allows SVG file uploads in frontend forms and you don't already sanitize uploaded SVG files. The problem has been patched in Kirby 3.5.4. Please update to this or a later version to fix the vulnerability. Frontend upload forms need to be patched separately depending on how they store the uploaded file(s). If you use `File::create()`, you are protected by updating to 3.5.4+. As a work around you can disable the upload of SVG files in your file blueprints.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-29460?

2 open source packages ship an affected version, including getkirby/cms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `getkirby/cms` | Packagist | All versions | 3.5.4 |
| `getkirby/cms` | Packagist | All versions | 3.5.4 |

Products: Getkirby Kirby.

## How do I fix CVE-2021-29460?

Upgrade getkirby/cms to 3.5.4 or later.

## Is CVE-2021-29460 being exploited?

There is no known exploitation of CVE-2021-29460 in the wild and no public exploit code.

Public exploit code:

- Kirby CMS 3.5.3.1 - 'file' Cross-Site Scripting (XSS) (exploitdb)

## Other vulnerabilities in getkirby kirby

- [CVE-2024-26483](https://insights.sbomify.com/CVE-2024-26483/): Kirby vulnerable to unrestricted file upload of user avatar images (high 8.8)
- [CVE-2024-41964](https://insights.sbomify.com/CVE-2024-41964/): Insufficient permission checks in the language settings in Kirby CMS (high 8.1)
- [CVE-2026-34587](https://insights.sbomify.com/CVE-2026-34587/): Kirby has Server-Side Template Injection (SSTI) via double template resolution in option rendering (high 7.6)
- [CVE-2023-38489](https://insights.sbomify.com/CVE-2023-38489/): Kirby vulnerable to Insufficient Session Expiration after a password change (high 7.3)
- [CVE-2021-41252](https://insights.sbomify.com/CVE-2021-41252/): Cross-site scripting (XSS) from writer field content in the site frontend (high 7.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-29460 and fix it if it is affected.

What it is: CVE-2021-29460 is a high-severity cross-site scripting vulnerability in getkirby kirby, published on 27 Apr 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-29460 in the wild and no public exploit code.

Affected packages and fixed versions:
- getkirby/cms (Packagist): affected all versions; fixed in 3.5.4
- getkirby/cms (Packagist): affected all versions; fixed in 3.5.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-29460/ (Markdown: https://insights.sbomify.com/CVE-2021-29460/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-29460
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-29460
- OSV: https://osv.dev/vulnerability/CVE-2021-29460

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-29460/
Summaries are generated and may contain mistakes; the official description above is the record.
