# CVE-2021-29471: Denial of service in Matrix Synapse

> Attackers can cause denial of service in Matrix Synapse by submitting push rules with inefficient wildcard patterns that degrade matching engine performance.

- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 May 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-x345-32rc-8h85, PYSEC-2021-135, UBUNTU-CVE-2021-29471

## What is CVE-2021-29471?

CVE-2021-29471 is a low-severity denial of service vulnerability in Fedoraproject Fedora, published on 11 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Synapse is a Matrix reference homeserver written in python (pypi package matrix-synapse). Matrix is an ecosystem for open federated Instant Messaging and VoIP. In Synapse before version 1.33.2 "Push rules" can specify conditions under which they will match, including `event_match`, which matches event content against a pattern including wildcards. Certain patterns can cause very poor performance in the matching engine, leading to a denial-of-service when processing moderate length events. The issue is patched in version 1.33.2. A potential workaround might be to prevent users from making custom push rules, by blocking such requests at a reverse-proxy.

Weakness: CWE-331 (Insufficient Entropy), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2021-29471?

3 open source packages ship an affected version, including matrix-synapse. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `matrix-synapse` | PyPI | All versions | 1.33.2 |
| `matrix-synapse` | PyPI | All versions | 1.33.2 |
| `matrix-synapse` | PyPI | All versions | 1.33.2 |

Products: Fedoraproject Fedora, Matrix Synapse.

## How do I fix CVE-2021-29471?

Upgrade matrix-synapse to 1.33.2 or later.

## Is CVE-2021-29471 being exploited?

There is no known exploitation of CVE-2021-29471 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-29471 and fix it if it is affected.

What it is: CVE-2021-29471 is a low-severity denial of service vulnerability in Fedoraproject Fedora, published on 11 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-29471 in the wild and no public exploit code.

Affected packages and fixed versions:
- matrix-synapse (PyPI): affected all versions; fixed in 1.33.2
- matrix-synapse (PyPI): affected all versions; fixed in 1.33.2
- matrix-synapse (PyPI): affected all versions; fixed in 1.33.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-29471/ (Markdown: https://insights.sbomify.com/CVE-2021-29471/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-29471
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-29471
- OSV: https://osv.dev/vulnerability/CVE-2021-29471

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-29471/
Summaries are generated and may contain mistakes; the official description above is the record.
