CVE-2021-29473 Out-of-bounds read in Exiv2::Jp2Image::doWriteMetadata

Low 2.5 Published Updated

An attacker can cause a denial of service by tricking a user into writing metadata to a crafted image file using the Exiv2 library.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Local or same network only
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2021-29473?

CVE-2021-29473 is a low-severity memory corruption vulnerability in Debian Debian Linux, published on 26 Apr 2021. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

Official description

Exiv2 is a C++ library and a command-line utility to read, write, delete and modify Exif, IPTC, XMP and ICC image metadata. An out-of-bounds read was found in Exiv2 versions v0.27.3 and earlier. Exiv2 is a command-line utility and C++ library for reading, writing, deleting, and modifying the metadata of image files. The out-of-bounds read is triggered when Exiv2 is used to write metadata into a crafted image file. An attacker could potentially exploit the vulnerability to cause a denial of service by crashing Exiv2, if they can trick the victim into running Exiv2 on a crafted image file. Note that this bug is only triggered when writing the metadata, which is a less frequently used Exiv2 operation than reading the metadata. For example, to trigger the bug in the Exiv2 command-line application, you need to add an extra command-line argument such as `insert`. The bug is fixed in version v0.27.4. Please see our security policy for information about Exiv2 security.

Weakness: CWE-125

Which versions are affected by CVE-2021-29473?

It affects 3 products.

Products include Debian Debian Linux, Exiv2 Exiv2, Fedoraproject Fedora.

How do I fix CVE-2021-29473?

Upgrade to a fixed version.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2021-29473 being exploited?

There is no known exploitation of CVE-2021-29473 in the wild and no public exploit code.

All Debian Debian Linux vulnerabilities

Sources

Also known as AZL-7211, CLEANSTART-2024-BO85307, DEBIAN-CVE-2021-29473, GHSA-7569-phvm-vwc2, UBUNTU-CVE-2021-29473.

Is CVE-2021-29473 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free