# CVE-2021-29473: Out-of-bounds read in Exiv2::Jp2Image::doWriteMetadata

> An attacker can cause a denial of service by tricking a user into writing metadata to a crafted image file using the Exiv2 library.

- **Severity:** Low 2.5 (`CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Apr 2021
- **Updated:** 3 Aug 2024
- **Also known as:** AZL-7211, CLEANSTART-2024-BO85307, DEBIAN-CVE-2021-29473, GHSA-7569-phvm-vwc2, UBUNTU-CVE-2021-29473

## What is CVE-2021-29473?

CVE-2021-29473 is a low-severity memory corruption vulnerability in Debian Debian Linux, published on 26 Apr 2021. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Exiv2 is a C++ library and a command-line utility to read, write, delete and modify Exif, IPTC, XMP and ICC image metadata. An out-of-bounds read was found in Exiv2 versions v0.27.3 and earlier. Exiv2 is a command-line utility and C++ library for reading, writing, deleting, and modifying the metadata of image files. The out-of-bounds read is triggered when Exiv2 is used to write metadata into a crafted image file. An attacker could potentially exploit the vulnerability to cause a denial of service by crashing Exiv2, if they can trick the victim into running Exiv2 on a crafted image file. Note that this bug is only triggered when writing the metadata, which is a less frequently used Exiv2 operation than reading the metadata. For example, to trigger the bug in the Exiv2 command-line application, you need to add an extra command-line argument such as `insert`. The bug is fixed in version v0.27.4. Please see our security policy for information about Exiv2 security.

Weakness: CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2021-29473?

It affects 3 products.


Products: Debian Debian Linux, Exiv2 Exiv2, Fedoraproject Fedora.

## How do I fix CVE-2021-29473?

Upgrade to a fixed version.

## Is CVE-2021-29473 being exploited?

There is no known exploitation of CVE-2021-29473 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-29473 and fix it if it is affected.

What it is: CVE-2021-29473 is a low-severity memory corruption vulnerability in Debian Debian Linux, published on 26 Apr 2021. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-29473 in the wild and no public exploit code.

Affected product: Debian Debian Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-29473/ (Markdown: https://insights.sbomify.com/CVE-2021-29473/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-29473
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-29473
- OSV: https://osv.dev/vulnerability/CVE-2021-29473

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-29473/
Summaries are generated and may contain mistakes; the official description above is the record.
