CVE-2021-29476 Insecure Deserialization of untrusted data in rmccue/requests
- Exploited in the wild
- Not known
- Fix
- Available
What is CVE-2021-29476?
CVE-2021-29476 is a critical vulnerability in WordPress Requests, published on 27 Apr 2021.
Official description
Requests is a HTTP library written in PHP. Requests mishandles deserialization in FilteredIterator. The issue has been patched and users of `Requests` 1.6.0, 1.6.1 and 1.7.0 should update to version 1.8.0.
Weakness: CWE-502
Which versions are affected by CVE-2021-29476?
2 open source packages ship an affected version, including rmccue/requests. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
rmccue/requests Packagist | From 1.6.0 | 1.8.0 |
rmccue/requests Packagist | From 1.6.0 | 1.8.0 |
Products include Wordpress Requests.
How do I fix CVE-2021-29476?
Upgrade rmccue/requests to 1.8.0 or later.
Is CVE-2021-29476 being exploited?
There is no known exploitation of CVE-2021-29476 in the wild and no public exploit code.
Sources
Also known as DEBIAN-CVE-2021-29476, GHSA-52qp-jpq7-6c54, UBUNTU-CVE-2021-29476.