{"answers":{"affected":"2 open source packages ship an affected version, including rmccue/requests. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-29476 in the wild and no public exploit code.","fix":"Upgrade rmccue/requests to 1.8.0 or later.","what":"CVE-2021-29476 is a critical vulnerability in WordPress Requests, published on 27 Apr 2021."},"fix_prompt":"Check this codebase for CVE-2021-29476 and fix it if it is affected.\n\nWhat it is: CVE-2021-29476 is a critical vulnerability in WordPress Requests, published on 27 Apr 2021. \nExploitation: There is no known exploitation of CVE-2021-29476 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- rmccue/requests (Packagist): affected from 1.6.0; fixed in 1.8.0\n- rmccue/requests (Packagist): affected from 1.6.0; fixed in 1.8.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-29476/ (Markdown: https://insights.sbomify.com/CVE-2021-29476/index.md)","id":"CVE-2021-29476","markdown":"https://insights.sbomify.com/CVE-2021-29476/index.md","name":"CVE-2021-29476","record":{"aliases":["DEBIAN-CVE-2021-29476","GHSA-52qp-jpq7-6c54","UBUNTU-CVE-2021-29476"],"analysis":null,"analysis_generated_by":null,"assigner":"GitHub_M","cpe":[{"product":"requests","vendor":"wordpress"}],"cvss":{"score":9.8,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"Requests is a HTTP library written in PHP. Requests mishandles deserialization in FilteredIterator. The issue has been patched and users of `Requests` 1.6.0, 1.6.1 and 1.7.0 should update to version 1.8.0.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Insecure Deserialization of untrusted data in rmccue/requests","id":"CVE-2021-29476","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":null,"year":"2021"},"n_packages":2,"n_references":2,"next":{"headline":"Vulnerability in the STRALGO LCS command","id":"CVE-2021-29477"},"packages":[{"ecosystem":"Packagist","fixed":["1.8.0"],"introduced":["1.6.0"],"last_affected":[],"package":"rmccue/requests","purl":null,"source":"GHSA-52qp-jpq7-6c54"},{"ecosystem":"Packagist","fixed":["1.8.0"],"introduced":["1.6.0"],"last_affected":[],"package":"rmccue/requests","purl":"pkg:composer/rmccue/requests","source":"GHSA-52qp-jpq7-6c54"}],"prev":{"headline":"PDF export allows arbitrary file reads","id":"CVE-2021-29475"},"products":["Requests"],"published":"2021-04-27","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["WordPress"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2021-29476/"}