# CVE-2021-29476: Insecure Deserialization of untrusted data in rmccue/requests


- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 27 Apr 2021
- **Updated:** 3 Aug 2024
- **Also known as:** DEBIAN-CVE-2021-29476, GHSA-52qp-jpq7-6c54, UBUNTU-CVE-2021-29476

## What is CVE-2021-29476?

CVE-2021-29476 is a critical vulnerability in WordPress Requests, published on 27 Apr 2021. 

### Official description

Requests is a HTTP library written in PHP. Requests mishandles deserialization in FilteredIterator. The issue has been patched and users of `Requests` 1.6.0, 1.6.1 and 1.7.0 should update to version 1.8.0.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2021-29476?

2 open source packages ship an affected version, including rmccue/requests. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rmccue/requests` | Packagist | From 1.6.0 | 1.8.0 |
| `rmccue/requests` | Packagist | From 1.6.0 | 1.8.0 |

Products: Wordpress Requests.

## How do I fix CVE-2021-29476?

Upgrade rmccue/requests to 1.8.0 or later.

## Is CVE-2021-29476 being exploited?

There is no known exploitation of CVE-2021-29476 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-29476 and fix it if it is affected.

What it is: CVE-2021-29476 is a critical vulnerability in WordPress Requests, published on 27 Apr 2021. 
Exploitation: There is no known exploitation of CVE-2021-29476 in the wild and no public exploit code.

Affected packages and fixed versions:
- rmccue/requests (Packagist): affected from 1.6.0; fixed in 1.8.0
- rmccue/requests (Packagist): affected from 1.6.0; fixed in 1.8.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-29476/ (Markdown: https://insights.sbomify.com/CVE-2021-29476/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-29476
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-29476
- OSV: https://osv.dev/vulnerability/CVE-2021-29476

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-29476/
Summaries are generated and may contain mistakes; the official description above is the record.
