# CVE-2021-29484: DOM XSS in Theme Preview

> Attackers can hijack Ghost Admin sessions via DOM XSS in an unused preview endpoint, requiring users to click a malicious link.

- **Severity:** Medium 6.8 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 29 Apr 2021
- **Updated:** 3 Aug 2024
- **Also known as:** BIT-ghost-2021-29484, GHSA-9fgx-q25h-jxrg

## What is CVE-2021-29484?

CVE-2021-29484 is a medium-severity cross-site scripting vulnerability in TryGhost Ghost, published on 29 Apr 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Ghost is a Node.js CMS. An unused endpoint added during the development of 4.0.0 has left sites vulnerable to untrusted users gaining access to Ghost Admin. Attackers can gain access by getting logged in users to click a link containing malicious code. Users do not need to enter credentials and may not know they've visited a malicious site. Ghost(Pro) has already been patched. We can find no evidence that the issue was exploited on Ghost(Pro) prior to the patch being added. Self-hosters are impacted if running Ghost a version between 4.0.0 and 4.3.2. Immediate action should be taken to secure your site. The issue has been fixed in 4.3.3, all 4.x sites should upgrade as soon as possible. As the endpoint is unused, the patch simply removes it. As a workaround blocking access to /ghost/preview can also mitigate the issue.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-29484?

3 open source packages ship an affected version, including ghost. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ghost` | Bitnami | From 4.0.0 | 4.3.3 |
| `ghost` | npm | From 4.0.0 | 4.3.3 |
| `ghost` | npm | From 4.0.0 | 4.3.3 |

Products: Ghost Ghost.

## How do I fix CVE-2021-29484?

Upgrade ghost to 4.3.3 or later.

## Is CVE-2021-29484 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-29484 exists.

Public exploit code:

- Ghost CMS <=4.32 - Cross-Site Scripting (nuclei): http/cves/2021/CVE-2021-29484.yaml

## Other vulnerabilities in TryGhost Ghost

- [CVE-2022-27139](https://insights.sbomify.com/CVE-2022-27139/): Arbitrary file upload in Ghost (critical 9.8)
- [CVE-2022-28397](https://insights.sbomify.com/CVE-2022-28397/): Arbitrary file upload in Ghost (critical 9.8)
- [CVE-2022-41654](https://insights.sbomify.com/CVE-2022-41654/): ghost vulnerable to unauthorized newsletter modification via improper access controls (critical 9.6)
- [CVE-2026-26980](https://insights.sbomify.com/CVE-2026-26980/): Ghost has a SQL Injection in its Content API (critical 9.4)
- [CVE-2024-34451](https://insights.sbomify.com/CVE-2024-34451/): Security feature bypass in n/a (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-29484 and fix it if it is affected.

What it is: CVE-2021-29484 is a medium-severity cross-site scripting vulnerability in TryGhost Ghost, published on 29 Apr 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-29484 exists.

Affected packages and fixed versions:
- ghost (Bitnami): affected from 4.0.0; fixed in 4.3.3
- ghost (npm): affected from 4.0.0; fixed in 4.3.3
- ghost (npm): affected from 4.0.0; fixed in 4.3.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-29484/ (Markdown: https://insights.sbomify.com/CVE-2021-29484/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-29484
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-29484
- OSV: https://osv.dev/vulnerability/CVE-2021-29484

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-29484/
Summaries are generated and may contain mistakes; the official description above is the record.
