# CVE-2021-29485: Remote Code Execution Vulnerability in Session Storage

> Attackers can achieve remote code execution via malicious deserialization in Ratpack session stores if the session mechanism is enabled.

- **Severity:** Critical 9.9 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Jun 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-hc33-32vw-rpp9

## What is CVE-2021-29485?

CVE-2021-29485 is a critical unsafe deserialization vulnerability in ratpack, published on 29 Jun 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Ratpack is a toolkit for creating web applications. In versions prior to 1.9.0, a malicious attacker can achieve Remote Code Execution (RCE) via a maliciously crafted Java deserialization gadget chain leveraged against the Ratpack session store. If one's application does not use Ratpack's session mechanism, it is not vulnerable. Ratpack 1.9.0 introduces a strict allow-list mechanism that mitigates this vulnerability when used. Two possible workarounds exist. The simplest mitigation for users of earlier versions is to reduce the likelihood of attackers being able to write to the session data store. Alternatively or additionally, the allow-list mechanism could be manually back ported by providing an alternative implementation of `SessionSerializer` that uses an allow-list.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2021-29485?

2 open source packages ship an affected version, including io.ratpack:ratpack-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.ratpack:ratpack-core` | Maven | All versions | 1.9.0 |
| `io.ratpack:ratpack-core` | Maven | All versions | 1.9.0 |

Products: Ratpack Project Ratpack.

## How do I fix CVE-2021-29485?

Upgrade io.ratpack:ratpack-core to 1.9.0 or later.

## Is CVE-2021-29485 being exploited?

There is no known exploitation of CVE-2021-29485 in the wild and no public exploit code.

## Other vulnerabilities in ratpack

- [CVE-2019-17513](https://insights.sbomify.com/CVE-2019-17513/): io.ratpack:ratpack-core vulnerable to Improper Neutralization of Special Elements in Output ('Injection') (high 7.5)
- [CVE-2021-29479](https://insights.sbomify.com/CVE-2021-29479/): Cached redirect poisoning via X-Forwarded-Host header (high 7.0)
- [CVE-2021-29481](https://insights.sbomify.com/CVE-2021-29481/): Client side sessions should not allow unencrypted storage (medium 6.5)
- [CVE-2021-29480](https://insights.sbomify.com/CVE-2021-29480/): Default client side session signing key is highly predictable (medium 4.4)
- [CVE-2019-11808](https://insights.sbomify.com/CVE-2019-11808/): Use of Cryptographically Weak Pseudo-Random Number Generator (PRNG) in Ratpack (low 3.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-29485 and fix it if it is affected.

What it is: CVE-2021-29485 is a critical unsafe deserialization vulnerability in ratpack, published on 29 Jun 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-29485 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.ratpack:ratpack-core (Maven): affected all versions; fixed in 1.9.0
- io.ratpack:ratpack-core (Maven): affected all versions; fixed in 1.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-29485/ (Markdown: https://insights.sbomify.com/CVE-2021-29485/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-29485
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-29485
- OSV: https://osv.dev/vulnerability/CVE-2021-29485

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-29485/
Summaries are generated and may contain mistakes; the official description above is the record.
