{"answers":{"affected":"2 open source packages ship an affected version, including highcharts. It affects 5 products.","exploited":"There is no known exploitation of CVE-2021-29489 in the wild and no public exploit code.","fix":"Upgrade highcharts to 9.0.0 or later.","what":"CVE-2021-29489 is a high-severity cross-site scripting vulnerability in Netapp Cloud Backup, published on 5 May 2021. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-29489 and fix it if it is affected.\n\nWhat it is: CVE-2021-29489 is a high-severity cross-site scripting vulnerability in Netapp Cloud Backup, published on 5 May 2021. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-29489 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- highcharts (npm): affected all versions; fixed in 9.0.0\n- highcharts (npm): affected all versions; fixed in 9.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-29489/ (Markdown: https://insights.sbomify.com/CVE-2021-29489/index.md)","id":"CVE-2021-29489","markdown":"https://insights.sbomify.com/CVE-2021-29489/index.md","name":"CVE-2021-29489","record":{"aliases":["CLSA-2026-1782867610","CLSA-2026-1782867614","CLSA-2026-1782867617","CLSA-2026-1782867618","CLSA-2026-1782867619","CLSA-2026-1782954029","GHSA-8j65-4pcq-xq95"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript charting library","requires_auth":"low_privilege","summary":"Unfiltered chart options in Highcharts allow attackers to execute arbitrary code in the user's browser via cross-site scripting.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"highcharts","vendor":"highcharts"},{"product":"cloud_backup","vendor":"netapp"},{"product":"oncommand_insight","vendor":"netapp"},{"product":"oncommand_workflow_automation","vendor":"netapp"},{"product":"snapcenter","vendor":"netapp"}],"cvss":{"score":7.6,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:L","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Highcharts JS is a JavaScript charting library based on SVG. In Highcharts versions 8 and earlier, the chart options structure was not systematically filtered for XSS vectors. The potential impact was that content from untrusted sources could execute code in the end user's browser. The vulnerability is patched in version 9. As a workaround, implementers who are not able to upgrade may apply DOMPurify recursively to the options structure to filter out malicious markup.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Options structure open to XSS if passed unfiltered","id":"CVE-2021-29489","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":"netapp:cloud_backup","products":["netapp:cloud_backup","netapp:oncommand_insight","netapp:oncommand_workflow_automation","netapp:snapcenter"],"type":"xss","year":"2021"},"n_packages":2,"n_references":2,"next":{"headline":"Unauthenticated GET requests through Remote Image endpoints","id":"CVE-2021-29490"},"packages":[{"ecosystem":"npm","fixed":["9.0.0"],"introduced":["0"],"last_affected":[],"package":"highcharts","purl":null,"source":"GHSA-8j65-4pcq-xq95"},{"ecosystem":"npm","fixed":["9.0.0"],"introduced":["0"],"last_affected":[],"package":"highcharts","purl":"pkg:npm/highcharts","source":"GHSA-8j65-4pcq-xq95"}],"prev":{"headline":"Creation of files outside the Download Folder through malicious PAR2 files","id":"CVE-2021-29488"},"products":["highcharts"],"published":"2021-05-05","related":[{"cvss_score":7.5,"headline":"Regular Expression Denial of Service in highcharts","id":"CVE-2018-20801","kev_date_added":null,"published":"2019-03-14"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["highcharts"]},"summary":"Unfiltered chart options in Highcharts allow attackers to execute arbitrary code in the user's browser via cross-site scripting.","url":"https://insights.sbomify.com/CVE-2021-29489/"}