# CVE-2021-29495: Nim stdlib httpClient does not validate peer certificates by default

> Nim's standard library HTTP client fails to validate SSL/TLS certificates by default, allowing man-in-the-middle attacks unless explicitly configured otherwise.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 May 2021
- **Updated:** 3 Aug 2024
- **Also known as:** DEBIAN-CVE-2021-29495, GHSA-9vqv-2jj9-7mqr, UBUNTU-CVE-2021-29495

## What is CVE-2021-29495?

CVE-2021-29495 is a medium-severity vulnerability in nim-lang security, published on 7 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Nim is a statically typed compiled systems programming language. In Nim standard library before 1.4.2, httpClient SSL/TLS certificate verification was disabled by default. Users can upgrade to version 1.4.2 to receive a patch or, as a workaround, set "verifyMode = CVerifyPeer" as documented.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2021-29495?

It affects 1 product.


Products: Nim-Lang Nim.

## How do I fix CVE-2021-29495?

Upgrade to a fixed version.

## Is CVE-2021-29495 being exploited?

There is no known exploitation of CVE-2021-29495 in the wild and no public exploit code.

## Other vulnerabilities in nim-lang security

- [CVE-2020-15690](https://insights.sbomify.com/CVE-2020-15690/): Other in n/a (critical 9.8)
- [CVE-2020-15692](https://insights.sbomify.com/CVE-2020-15692/): Command injection in n/a (critical 9.8)
- [CVE-2021-21372](https://insights.sbomify.com/CVE-2021-21372/): Nimble arbitrary code execution for specially crafted package metadata (high 8.3)
- [CVE-2021-21374](https://insights.sbomify.com/CVE-2021-21374/): Nimble fails to validate certificates due to insecure httpClient defaults (high 8.1)
- [CVE-2021-21373](https://insights.sbomify.com/CVE-2021-21373/): Nimble falls back to insecure http url when fetching packages (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-29495 and fix it if it is affected.

What it is: CVE-2021-29495 is a medium-severity vulnerability in nim-lang security, published on 7 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-29495 in the wild and no public exploit code.

Affected product: nim-lang security. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-29495/ (Markdown: https://insights.sbomify.com/CVE-2021-29495/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-29495
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-29495
- OSV: https://osv.dev/vulnerability/CVE-2021-29495

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-29495/
Summaries are generated and may contain mistakes; the official description above is the record.
