{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-29502 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2021-29502 yet. Limit exposure of the affected software until one is available.","what":"CVE-2021-29502 is a high-severity code injection vulnerability in retke Laggrons-Dumb-Cogs, published on 10 May 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-29502 and fix it if it is affected.\n\nWhat it is: CVE-2021-29502 is a high-severity code injection vulnerability in retke Laggrons-Dumb-Cogs, published on 10 May 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2021-29502 in the wild and no public exploit code.\n\nAffected product: retke Laggrons-Dumb-Cogs. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-29502/ (Markdown: https://insights.sbomify.com/CVE-2021-29502/index.md)","id":"CVE-2021-29502","markdown":"https://insights.sbomify.com/CVE-2021-29502/index.md","name":"CVE-2021-29502","record":{"aliases":["GHSA-834g-67vv-m9wq"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Discord bot plugin","requires_auth":"low_privilege","summary":"Attackers can execute arbitrary code and access sensitive information via unsanitized templates in the WarnSystem module of Laggrons-Dumb-Cogs.","user_interaction":"required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"warnsystem","vendor":"warnsystem_project"}],"cvss":{"score":7.3,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"},{"id":"CWE-74","name":"Improper Neutralization of Special Elements in Output Used by a Downstream Component"}],"description":"WarnSystem is a cog (plugin) for the Red discord bot. A vulnerability has been found in the code that allows any user to access sensible informations by setting up a specific template which is not properly sanitized. The problem has been patched in version 1.3.18. Users should update and type `!warnsysteminfo` to check that their version is 1.3.18 or above. As a workaround users may unload the WarnSystem cog or disable the `!warnset description` command globally.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Remote code execution in the WarnSystem module of Laggrons-Dumb-Cogs","id":"CVE-2021-29502","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"code_injection","year":"2021"},"n_packages":0,"n_references":2,"next":{"headline":"Improper Neutralization of Script-Related HTML Tags in Notes","id":"CVE-2021-29503"},"packages":[],"prev":{"headline":"Remote code execution in ticketer","id":"CVE-2021-29501"},"products":["Laggrons-Dumb-Cogs"],"published":"2021-05-10","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["retke"]},"summary":"Attackers can execute arbitrary code and access sensitive information via unsanitized templates in the WarnSystem module of Laggrons-Dumb-Cogs.","url":"https://insights.sbomify.com/CVE-2021-29502/"}