# CVE-2021-29502: Remote code execution in the WarnSystem module of Laggrons-Dumb-Cogs

> Attackers can execute arbitrary code and access sensitive information via unsanitized templates in the WarnSystem module of Laggrons-Dumb-Cogs.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 10 May 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-834g-67vv-m9wq

## What is CVE-2021-29502?

CVE-2021-29502 is a high-severity code injection vulnerability in retke Laggrons-Dumb-Cogs, published on 10 May 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

WarnSystem is a cog (plugin) for the Red discord bot. A vulnerability has been found in the code that allows any user to access sensible informations by setting up a specific template which is not properly sanitized. The problem has been patched in version 1.3.18. Users should update and type `!warnsysteminfo` to check that their version is 1.3.18 or above. As a workaround users may unload the WarnSystem cog or disable the `!warnset description` command globally.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2021-29502?

It affects 1 product.


Products: Warnsystem Project Warnsystem.

## How do I fix CVE-2021-29502?

No fix has been published for CVE-2021-29502 yet. Limit exposure of the affected software until one is available.

## Is CVE-2021-29502 being exploited?

There is no known exploitation of CVE-2021-29502 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-29502 and fix it if it is affected.

What it is: CVE-2021-29502 is a high-severity code injection vulnerability in retke Laggrons-Dumb-Cogs, published on 10 May 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-29502 in the wild and no public exploit code.

Affected product: retke Laggrons-Dumb-Cogs. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-29502/ (Markdown: https://insights.sbomify.com/CVE-2021-29502/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-29502
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-29502
- OSV: https://osv.dev/vulnerability/CVE-2021-29502

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-29502/
Summaries are generated and may contain mistakes; the official description above is the record.
