# CVE-2021-29505: XStream is vulnerable to a Remote Command Execution attack

> Remote attackers can execute arbitrary host commands via manipulated input streams if XStream's security whitelist is not configured.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 May 2021
- **Updated:** 7 Oct 2026
- **Also known as:** DEBIAN-CVE-2021-29505, DLA-2704-1, GHSA-7chv-rrw6-w6fc, OESA-2021-1208, RHSA-2021:2683, SUSE-SU-2021:1995-1, UBUNTU-CVE-2021-29505, openSUSE-SU-2021:0911-1, openSUSE-SU-2021:1995-1

## What is CVE-2021-29505?

CVE-2021-29505 is a high-severity unsafe deserialization vulnerability in Debian Debian Linux, published on 28 May 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

XStream is software for serializing Java objects to XML and back again. A vulnerability in XStream versions prior to 1.4.17 may allow a remote attacker has sufficient rights to execute commands of the host only by manipulating the processed input stream. No user who followed the recommendation to setup XStream's security framework with a whitelist limited to the minimal required types is affected. The vulnerability is patched in version 1.4.17.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2021-29505?

2 open source packages ship an affected version, including com.thoughtworks.xstream:xstream. It affects 17 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.thoughtworks.xstream:xstream` | Maven | All versions | 1.4.17 |
| `com.thoughtworks.xstream:xstream` | Maven | All versions | 1.4.17 |
| `xstream` | Red Hat:enterprise_linux:7::client | All versions | 0:1.3.1-14.el7_9 |
| `xstream-javadoc` | Red Hat:enterprise_linux:7::client | All versions | 0:1.3.1-14.el7_9 |
| `xstream` | Red Hat:enterprise_linux:7::computenode | All versions | 0:1.3.1-14.el7_9 |
| `xstream-javadoc` | Red Hat:enterprise_linux:7::computenode | All versions | 0:1.3.1-14.el7_9 |
| `xstream` | Red Hat:enterprise_linux:7::server | All versions | 0:1.3.1-14.el7_9 |
| `xstream-javadoc` | Red Hat:enterprise_linux:7::server | All versions | 0:1.3.1-14.el7_9 |
| `xstream` | Red Hat:enterprise_linux:7::workstation | All versions | 0:1.3.1-14.el7_9 |
| `xstream-javadoc` | Red Hat:enterprise_linux:7::workstation | All versions | 0:1.3.1-14.el7_9 |
| `xstream` | SUSE:Linux Enterprise Module for Development Tools 15 SP2 | All versions | 1.4.17-3.11.2 |
| `xstream` | SUSE:Linux Enterprise Module for Development Tools 15 SP3 | All versions | 1.4.17-3.11.2 |
| `xstream` | SUSE:Manager Server Module 4.1 | All versions | 1.4.17-3.11.2 |
| `xstream` | SUSE:Manager Server Module 4.2 | All versions | 1.4.17-3.11.2 |
| `xstream` | openSUSE:Leap 15.2 | All versions | 1.4.17-lp152.2.9.1 |
| `xstream` | openSUSE:Leap 15.3 | All versions | 1.4.17-3.11.2 |

Products: Debian Debian Linux, Fedoraproject Fedora, Netapp Snapmanager, Oracle Banking Cash Management, Oracle Banking Corporate Lending Process Management, Oracle Banking Credit Facilities Process Management, Oracle Banking Supply Chain Finance, Oracle Banking Trade Finance Process Management, Oracle Business Activity Monitoring, Oracle Communications Brm - Elastic Charging Engine, Oracle Communications Unified Inventory Management, Oracle Enterprise Manager Ops Center, Oracle Retail Customer Insights, Oracle Retail Xstore Point of Service, Oracle Webcenter Portal, Oracle Webcenter Sites, Xstream Xstream.

## How do I fix CVE-2021-29505?

Upgrade com.thoughtworks.xstream:xstream to 1.4.17 or later.

## Is CVE-2021-29505 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-29505 exists.

Public exploit code:

- 对CVE-2021-29505进行复现，并分析学了下Xstream反序列化过程 (github_poc): https://github.com/MyBlackManba/CVE-2021-29505
- https://github.com/cuijiung/xstream-CVE-2021-29505 (github_poc): https://github.com/cuijiung/xstream-CVE-2021-29505
- XStream <1.4.17 - Remote Code Execution (nuclei): http/cves/2021/CVE-2021-29505.yaml

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-29505 and fix it if it is affected.

What it is: CVE-2021-29505 is a high-severity unsafe deserialization vulnerability in Debian Debian Linux, published on 28 May 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-29505 exists.

Affected packages and fixed versions:
- com.thoughtworks.xstream:xstream (Maven): affected all versions; fixed in 1.4.17
- com.thoughtworks.xstream:xstream (Maven): affected all versions; fixed in 1.4.17

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-29505/ (Markdown: https://insights.sbomify.com/CVE-2021-29505/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-29505
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-29505
- OSV: https://osv.dev/vulnerability/CVE-2021-29505

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-29505/
Summaries are generated and may contain mistakes; the official description above is the record.
