CVE-2021-29506 Navigate endpoint is vulnerable to regex injection that may lead to Denial of Service.
Attackers can cause a Denial of Service in GraphHopper via regex injection in the Navigate endpoint, requiring an upgrade to patched versions.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-29506?
CVE-2021-29506 is a medium-severity denial of service vulnerability in graphhopper, published on 13 May 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
GraphHopper is an open-source Java routing engine. In GrassHopper from version 2.0 and before version 2.4, there is a regular expression injection vulnerability that may lead to Denial of Service. This has been patched in 2.4 and 3.0 See this pull request for the fix: https://github.com/graphhopper/graphhopper/pull/2304
Weakness: CWE-400
Which versions are affected by CVE-2021-29506?
2 open source packages ship an affected version, including com.graphhopper:graphhopper-nav. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
com.graphhopper:graphhopper-nav Maven | All versions | 2.4 |
com.graphhopper:graphhopper-nav Maven | All versions | 2.4 |
Products include Graphhopper Graphhopper.
How do I fix CVE-2021-29506?
Upgrade com.graphhopper:graphhopper-nav to 2.4 or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2021-29506 being exploited?
There is no known exploitation of CVE-2021-29506 in the wild and no public exploit code.
Other vulnerabilities in graphhopper
Sources
Also known as GHSA-hf44-3mx6-vhhw.